2

We've just bought a new Dell PowerEdge R620 to replace the oldest of our 3 hosts in our vSphere cluster. The existing hosts are connected to our EMC VNX 5300 SAN using gigabit ethernet which is a pretty horrible bottleneck, so I bought this server equipped with a Brocade 825 Fibre Channel card.

The problem I'm having is that despite adding the new host to a new storage group containing our 3 LUNs and setting up a host initiator for the fibre channel connection. ESXi can't see any devices or paths (it sees the card with its two ports). The host is connected directly to the back of the SAN, we can't afford a switch and I didn't believe it was necessary.

Initiators config:

WWN: Copied and pasted from the ESXi storage adapters section. Deleted the space in the middle and added a colon.

Initiator Type: CLARiiON Open

Failover Mode: Active-Active

Advanced: ArrayCommPath(LUN Z) is checked and Unit Serial Number is Array (I've tried LUN as well)

I'm aware there is a vSphere plugin for this. But as we have a 3 host licence I can't connect up this host until it is working properly.

The port it showing as up at 8Gb and the light is solid green on the back of the SAN and HBA.

Any help is much appreciated. I feel like I've tried everything...

For future readers of this. The full solution: Thanks so much for the pointer Basil! This put me on the right track. For future readers of this you need the "VMware ESXi 5.5 BCU - ESX CLI plug-in". Which is currently available from QLogic.com

Commands courtesy of StorageNetworks.com:

esxcli software vib install --no-sig-check --maintenance-mode -d <zipfilepath>
cd /opt/brocade/bin
./bcu port --topology 1/0 loop
./bcu port --disable 1/0
./bcu port --enable 1/0

If you have an 825 then repeat last 3 commands for port 1/1.

1

You probably need to configure that Brocade card for FC-AL (that's arbitrated loop, or no-fabric mode, and it's needed for direct storage connections). Normal HBAs (like QLogic and Emulex) do it out of the box, but Brocade (at least the 815s, presumably your 825 as well) don't.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.