The new version of iOS 8 as well as Android supports Wi-Fi Calling with multiple cellular providers including T-Mobile in the US. I am currently running pfSense as the primary Internet gateway for several commercial clients.

On my pfSense gateway, I would like to enable QoS and prioritize Wi-Fi calling and other VoIP traffic above the rest of the traffic on the network. I envision at least 10-20 users simultaneously using Wi-Fi calling on the network, and I want to minimize jitter and bandwidth contention for these connections. In addition, I would like to limit the number of people that can successfully enable Wi-Fi calling, if possible.

In my testing with T-Mobile US, I've seen that a UDP IPsec connection is made to an IP in T-Mobile's IP address space on port 4500. However, I'm having trouble tracking other connection information from there.

My understanding is that the Traffic Shaper function within pfSense is what should be used, but I'm not sure what settings should be chosen. In addition, I'm guessing that I can limit the number of users using Wi-Fi calling using some of the Advanced Settings in the Firewall Rules, but not sure what my approach should be there. Am I going about this the right way?

  • 2
    Question should be reopened. I reworded the question, but this is particularly relevant to any network administrators in corporate environments that may see a large influx of these devices and want to perform QoS, especially in BYOD environments. In addition, there's not much public information to help find the answer, so this will require a bit of packet inspection, tcpdump, and/or Wireshark to figure it out. – reedog117 Sep 17 '14 at 17:49
  • An official answer from T-Mobile also recommends the following: TCP 5060 TCP 5061 UDP 52000-59999 See support.t-mobile.com/message/423951#423951 – ATSiem Oct 29 '14 at 20:28
  • Note the following: you can priorize your upload only until the router of your control.. everything after that is the decision of your ISP if it honors your settings or not.. – Dennis Nolte Aug 5 '15 at 9:47

The following simple fix made a world of difference in T-Mobile Wifi Calling quality on my iPhone 5S on my Asus RT-AC66U! This is based on the findings in the original question here, as well as a T-Mobile support link.

  1. Go to QoS Setup for your router, default is:
  2. Enable QoS
  3. Add the following User-Defined QoS rules as 'Highest' priority and move everything else to High or lower. Below is a picture of the defaults, after I completed step 3.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.