2

I am using Cisco 3750G stacked switch configured with etherchannel and connected to ESXi Server configured with NIC teaming; Load balancing as router based on IP Hash. Cisco Switch configuration: ( VID 199 is ESXi-Mgmt)

interface Port-channel4

description "ESXi Mgmt"

Switchport turnk encapsulation dot1q

switchport trunk native vlan 4094

switchport trunk allowed vlan 199,200

switchport mode trunk

spanning-tree portfast trunk

!

interface GigabitEthernet2/0/2

Switchport turnk encapsulation dot1q

switchport trunk native vlan 4094

switchport trunk allowed vlan 199,200

switchport mode trunk

channel-group 4 mode on

!

interface GigabitEthernet3/0/2

Switchport turnk encapsulation dot1q

switchport trunk native vlan 4094

switchport trunk allowed vlan 199,200

switchport mode trunk

channel-group 4 mode on

Configuration of ESXi Host:

  • Created new vmkernel portgroup called ESXi-Mgmt and added NIC0 and NIC4(additional NIC card)

  • configured vswitch and portgroup with NIC teaming as | Load balancing: Route based on IP Hash | Network Failover Detection: link status only | Notify swtiches: Yes | Fallback: Yes

  • configured IP for port group as 10.1.199.9

~ # esxcfg-vswitch -l

Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks

vSwitch0         3322        4           128               1500    vmnic1

  PortGroup Name        VLAN ID  Used Ports  Uplinks

  VM Network            0        0           vmnic1

  ESXi Management       0        1           vmnic1

Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks

vSwitch1         3322        6           128               1500    vmnic0,vmnic4

  PortGroup Name        VLAN ID  Used Ports  Uplinks

  ESXi-Mgmt             199      1           vmnic0,vmnic4

NOTE: I also have NIC1 connected (different subnet) so that I can access using my Laptop being in the same network. ( setup at the time of ESXi installation)

I have a server connected to Cisco Switch port configured as Access switchport for VLAN 199.

ISSUE:I can ping the IP 10.1.199.9 from the server mentioned above but can't access it using vsphere web client.

would someone please help me resolve the issue as I have not had any luck finding any solution so far? setup seems to be correct when looking into guides.

2

Turn off the Etherchannel. You really can't make use of it in the situation you've described. If you're using a standard vSwitch, you can set load balancing policies and use multiple NICs using IP hash, but this is really being done on the ESXi side. LACP/Etherchannel doesn't come into play unless you are using a Distributed Switch (dvSwitch or vDS).

There is the possibility of creating static aggregation without the distributed switch, but it offers no benefit over the default ESXi load balancing. It's not common.

If you don't have something that looks like this, where you've defined a "Link Aggregation Group", you may be going down the wrong path.

enter image description here

  • At the moment I am using vswitch and have not planned to use vDistributed Switch unless it is must. I will environment of 3 x ESXi 5.5 hosts under one vcentre cluster. set load balancing policies and use multiple NICs using IP hash, but this is really being done on the ESXi side. – Amir Sep 15 '14 at 12:05
  • That should be fine. Why do you need Etherchannel in your use case? – ewwhite Sep 15 '14 at 12:06
  • At the moment I am using vswitch and have not planned to use vDistributed Switch unless it is must. I will environment of 3 x ESXi 5.5 hosts under one vcentre cluster. I have set load balancing policies and used 2 NICs using IP hash in ESXi host. I also looked into vmware KB: one of them kb.vmware.com/selfservice/microsites/… – Amir Sep 15 '14 at 12:11
2

The response about LACP not being supported by standard vSwitch is correct. Etherchannel is supported by vSwitch though. So you're probably wondering what's wrong with etherchannel?

When teaming with etherchannel, a single TCP/UDP session will not enjoy the aggregate bandwidth of all links in your channel. It will be limited to a single link. So if you have 2 x 1GB links in your etherchannel, any one session will never exceed 1GB. Other TCP/UDP sessions will get balanced over all the links, helping to prevent saturation, but with a single TCP/UDP session, true aggregate bandwidth will never be achieved.

Etherchannel still has uses though. It does help prevent link saturation when there are multiple sessions being balanced over the channel. It's also useful for creating fault tolerant connections from a switch stack, where you take ports from separate switches that participate in a stack, or chassis backplane, and put them in a cross-stack etherchannel, so a single switch failure won't take down your esx host.

Standby NIC's assigned to the vSwitch provide fault tolerance but, there is some interruption involved, due to esx having populate upstream switch CAM tables with MAC addresses. Etherchannel is a step above ESX NIC failover.

1

I manage to fix the issue. I basically configured ESXi with etherchannel & VID settings as suggested by Vmware first. Once etherchannel is set, connection to esxi host was disconnect which means etherchannel is configured correctly. then, I configured Cisco switchports to be in etherchannel with correct VID. This worked like a piece of cake.

0

Are you using a vDistributed Switch (vDS) or a regular vSwitch? LACP only fully works with vDS and that's a feature that requires the Enterprise Plus licence.

Have a read of THIS and THIS.

  • At the moment I am using vswitch and have not planned to use vDistributed Switch unless it is must. I will environment of 3 x ESXi 5.5 hosts. – Amir Sep 15 '14 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.