I recently changed over our old login script that mapped network drives over to group policy preference drive maps. Worked through a few issues at first, but appears to be working fine for all of our users. However, one issue that I'm having on one Windows 7 workstation, is that it's mapping all of the drives it's supposed to, but it's also mapping one of the network drives multiple times. The longer his computer goes unrestarted, the more copies of this drive get mapped. It starts with the actual drive letter, S. Then you start to see Z, Y, X, etc starting to appear. One day he had at least 10 copies of this drive appear.

Anyone know how to troubleshoot this?

3 Answers 3


Another couple common spots to look for problems like this are listed in my screenshots below. You've likely checked these settings, but in case you haven't, it would be worth your while to do so. Obviously we're dealing with User Preferences here and you already know that, but for the sake of future users reading this question I'll give the location in GP; User Configuration > Preferences > Windows Settings > Drive Maps

Check these settings:

enter image description here

enter image description here

Again, you may have checked these settings so forgive me if I'm stating the obvious, but you'll also note that above the red highlighted area in my first screenshot is the option labeled "Reconnect:". Running with this checked in tandem with having the option of "Apply once and do no reapply" on the Common tab of the Drive Map Properties usually prevents the issue you're having; I say usually because if, like the other users in this thread mentioned, you have scripts running elsewhere it will make it hard to narrow down what is causing the issues.


That sounds more like you've got an old script with a NET USE * ... command in it, and less like a problem with Group Policy Preference. Using drive letters starting with "Z:" and moving backwards is exactly the behavior of NET USE *.

I'd run a "Resultant Set of Policy" as that user and take a look at all the scripts assigned to run as Logon Scripts. I'd also look over the Start Menu "Startup" folder and registry "Legacy Run" keys (HKCU\Software\Microsoft\Windows\CurrentVersion\Run and RunOnce) to make sure there's nothing in there.


The behavior of Group Policy Preference, with respect to dynamically choosing drive letters (the 'Use first available starting at:' setting) moves in descending order through the alphabet. That's part of what makes me think this isn't GPP doing this.

You could consider enabling Audit Process Tracking and watching the Event Log to see if something is running net.exe. That'll take some work to parse thru the log, for sure, but that might just tell you.

Based on these "stacking up" during a single logon session my gut says you've got something calling net.exe repeatedly during the logon session. Does the user run any apps that are started via script (rather than just a shortcut to an EXE)?

  • I'll check into that, The odd bit is that the drives appear over time while the user is logged in. Usually login scripts run only once though
    – Brett G
    Sep 15, 2014 at 16:38
  • @BrettG - I see. That does cast doubt on a script. I was reading "...the longer his computer goes unrestarted..." as referring to restarts, not logon/logoff cycles. Sep 15, 2014 at 16:48
  • Unfortunately neither of those solutions worked.
    – Brett G
    Sep 17, 2014 at 15:43

It really feels like the NET USE * behavior mentioned by Evan. One thing you can try is checking if New connections will be remembered is displayed when running a NET USE command. If it is the case, you can try to change this default with NET USE /PERSIST:NO and see if the problem continues or not... If it does not (or if it persists and the setting comes back to connections will be remembered) it seems a very strong indicator of a startup script connecting the drive. To locate it, you can try with the AutoRuns tool (http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx), which does a thorough scan of the most common (and some less common) autostarting places.

  • NET USE /PERSIST was on before. I changed it several days ago, still having the issue after trying many other resolutions. I'll check out the autoruns tool though
    – Brett G
    Sep 17, 2014 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.