0

I am trying to connect to my server (Synology DS212) using ssh xxx@yyy -p 22222 -vvv but I can't and I obtain the following error:

OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011
debug1: Reading configuration data /Users/xxxxx/.ssh/config
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug1: /etc/ssh_config line 102: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to yyyyyyy [xx.xx.xx.xx] port 22222.
debug1: Connection established.
debug1: identity file /Users/xxxxx/.ssh/id_rsa type -1
debug1: identity file /Users/xxxxx/.ssh/id_rsa-cert type -1
debug1: identity file /Users/xxxxx/.ssh/id_dsa type -1
debug1: identity file /Users/xxxxx/.ssh/id_dsa-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.2
ssh_exchange_identification: read: Operation timed out

The connection works on an other computer but not on mine (macbook pro). This connection does not use any keys (even when I have deleted them it did not work).

Do you have any idea of the trouble?

Feeback: The issue is due to the configuration of the network on which I executed ssh xxx@yyy -p 22222 -vvv. The router allows me to open connections on every ports but it blocks every incoming connections on non standard port for ssh (non 22 port). In my case, there are non solution.

Advices: try tcpdump on computer and server at the same time for monitor incoming and outgoing connections.

  • You can check this link. Also if its possible to check in secure log of your server then check there. – Pratap Sep 17 '14 at 14:59
  • @PratapSingh I have used tcpdump and I obtain some lines: 15:22:14.074084 IP zzzz.ssh > yyyy.52113: Flags [P.], seq 1:33, ack 1, win 362, options [nop,nop,TS val 3701306 ecr 358037802], length 32. So the server receives the connexion but something seems to be wrong (maybe blocked ports on my network... but it is strange because I can connect to other server using ssh). – Guuk Sep 17 '14 at 15:23
  • allow your IP on /etc/hosts.allow file and see if you are able to access from mac book. But it seems that timeout error points to local firewall so better you should disable your firewall on your macbook and check. – Pratap Sep 17 '14 at 15:24
  • @PratapSingh I did this but the result is the same.... – Guuk Sep 17 '14 at 16:01
  • in case you are able to access the server from different location the login to server and check what is there in secure log though I doubt anything will be there as its local to your local n/w check if you have any n/w firewall or anything else can provide traceroute and telnet information in your question. – Pratap Sep 17 '14 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.