I'm trying out Win7, and i'm trying to connect to the networked samba share as I have been able to in Vista & XP with no issues. Samba is running on Ubuntu, if that helps.

I've tried changing the following in the local security policy as i've seen on as the answer on some sites, and it's still not working:

Local Policies - Security Options

Network security: LAN Manager authentication level Send LM & NTLM responses

Minimum session security for NTLM SSP

Disable Require 128-bit encryption

I am getting this in my samba error log:

[2009/09/06 15:15:53, 0] lib/util_sock.c:read_data(534)
  read_data: read failure for 4 bytes to client Error = Connection reset by peer

Has anyone seen this issue yet?

2 Answers 2


Are you running Samba 3? If you are try adding this to the smb.conf

client ntlmv2 auth = yes

In case you've tripped across this like I have, and the good answer from @Josh Budde hasn't helped, you might find that your Samba setup is using ADS as its authentication source (you'll find the line "security = ADS" in your smb.conf).

In my case I was trying to access a Samba source on a remote, non-trusted Domain, and when entering login details I entered the username in the Windows NT format e.g. DOMAIN\first.last.

Even though the credentials were correct, the Samba server would reject the credentials and the Samba error log had the message as per the Op.

The fix is really easy - enter your username in the LDAP/ADS format of [email protected] (e.g. [email protected]).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .