3

I'm trying to enable postfix auth. I'm editing the this section from /etc/dovecot/conf.d/10-master.conf

# Postfix smtp-auth
unix_listener /var/spool/postfix/private/auth {
    mode = 0666
    user = postfix
    group = postfix
}

But after I restart dovecot I get this error:

Starting Dovecot Imap: doveconf: Fatal: Error in configuration file /etc/dovecot/conf.d/10-master.conf line 88: Unknown setting: unix_listener
                                                       [FAILED]
  • 1
    Make sure to put this unix_listener block in a service auth { ... } block. – user186340 Sep 17 '14 at 3:26
6

You should put this unix_listener block inside a service auth block, like so :

service auth {
    unix_listener /some/path { ... }
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.