4

I have a bit of a problem; I have configured postfix to use dovecot for SMTP AUTH, therefore I had to specify dovecot authentication in the main.cf file. The problem is, I need to also authenticate to my smarthost for outgoing SMTP relaying. I can't seem to do both at once. I can either configure my smart host, or I can configure dovecot auth.

main.cf file:

relayhost = relay.jangosmtp.net:2525
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/relay_passwd

smtp_sasl_type = dovecot
smtpd_sasl_path = private/auth
smtpd_sasl_authenticated_header = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions =
    permit_mynetworks
    permit_sasl_authenticated
    reject_unauth_destination

smtpd_tls_key_file = /etc/postfix/certs/key.pem
smtpd_tls_cert_file = /etc/postfix/certs/cert.pem

I tried to combine the two together, but postfix will not send mail via the smarthost, although it will still authenticate SMTP submission users.

maillog gives the following error:

Sep 16 23:59:00 hg-gv postfix/smtp[16631]: warning: unsupported SASL client implementation: dovecot
Sep 16 23:59:00 hg-gv postfix/smtp[16631]: fatal: SASL library initialization

This makes sense, but I need to have dovecot enabled to authenticate SMTP users.

I have no idea what to do about this.

  • 7
    smtp != smtpd. Replace smtp_sasl_type with smtpd_sasl_type and try to send email again. – masegaloeh Sep 17 '14 at 5:04
3

Note: smtp != smtpd

Parameter smtp_sasl_type with dovecot was unsupported. Maybe you mean smtpd_sasl_type = dovecot instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.