1

Email's being generated from my test alarms in vCenter are not being forwarded to the proxy / SMTP server configured. I run tail -f on the mail log file when generating a test alarm and I can see the following

2014-09-17T15:05:10+00:00 mgt-vm-vcenter sendmail[542]: s8HF5AgH000542: from=root, size=565, class=0, nrcpts=1, msgid=<201409171505.s8HF5AgH000542@mgt-vm-vcenter.amvi.local>, relay=root@localhost

Then after a long wait (DNS?) I get:

2014-09-17T15:06:49+00:00 mgt-vm-vcenter sendmail[545]: s8HF5AHJ000545: from=<root@mgt-vm-vcenter.amvi.local>, size=805, class=0, nrcpts=1, msgid=<201409171505.s8HF5AgH000542@mgt-vm-vcenter.amvi.local>, proto=ESMTP, daemon=MTA, relay=mgt-vm-vcenter.amvi.local [127.0.0.1]
2014-09-17T15:06:49+00:00 mgt-vm-vcenter sendmail[545]: s8HF5AHJ000545: to=<my.email@domain.co.uk>, delay=00:00:00, mailer=relay, pri=30805, dsn=4.4.3, stat=queued
2014-09-17T15:06:49+00:00 mgt-vm-vcenter sendmail[542]: s8HF5AgH000542: to=my.email@domain.co.uk;, ctladdr=root (0/0), delay=00:01:39, xdelay=00:01:39, mailer=relay, pri=30565, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (s8HF5AHJ000545 Message accepted for delivery)

When I run netstat I can not see any outgoing connections to the SMTP server and the log above just spews out over and over again and the mail get's stuck when I check mailq

Can anyone suggest why this is happening? I have tested this on another setup and I expect details of the SMTP server to be show nnext but this never happs so it looks as though vCenter can not contact the email server. IPtables is off on the SMTP server and is routing other email fine from other servers. So it must be sendmail on vCenter VA.

Update ** /etc/Hosts file output:

127.0.0.1  mgt-vm-vcenter.amvi.local mgt-vm-vcenter localhost
127.0.0.2 mgt-vm-vcenter.amvi.local mgt-vm-vcenter localhost
::1     mgt-vm-vcenter.amvi.local mgt-vm-vcenter localhost ip6-localhost ip6-loopback

I had to add .2 to the hosts file or sendmail complains...

Can anyone suggest any help or offer any configuration advise / tests on how to fix such issues?

  • Do two basic test to provide more clues. 1) How long does it take to get SMTP greeting? telnet 127.0.0.1 25 2) Does sending a test mail as root with DNS tracking provides any clues? (echo subject: test; echo) | /usr/sbin/sendmail -d8.20 -v -i my.email@domain.co.uk – AnFi Sep 20 '14 at 6:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.