Has anyone tried to install mod_fastcgi on CentOS7/httpd yet?

Since it's not in the epel or fusion repos, I tried the el6 rpm, which wasn't working (httpd said: Cannot load modules/mod_fastcgi.so into server: /etc/httpd/modules/mod_fastcgi.so: undefined symbol: unixd_config).

Compiling mod_fastcgi (# make top_dir=/usr/lib64/httpd) from source failed too with a thousands of errors like that:

/usr/include/httpd/http_config.h:574:32: error: request for member 'connection' in something not a structure or union

mod_fastcgi.c:2881:5: warning: passing argument 6 of 'ap_log_rerror_' from incompatible pointer type [enabled by default]
     ap_log_rerror(FCGI_LOG_ERR_NOERRNO, r, "FastCGI: access denied: %s", r->uri);

SELINUX is already disabled (to exclude that as reason for "access denied")

I also installed the requirements for compiling fastcgi: httpd-devel libtool make gcc apr apr-devel.

Since mod_fastcgi is IMHO the common way to connect to PHP-FPM, I really can't imagine that fastcgi is not meant for CentOS 7 so I assume I'm doing something wrong.

Unfortunately, mod_proxy's support for socket connections starts at httpd 2.4.10 and CentOS 7 repos are only 2.4.6 and I'd like to avoid compiling apache2 (and really want to use fastcgi and stay with fpm-sockets)

Did I may miss anything that obsoleted fastcgi? If not, my wish would be to get mod-fastcgi successfully compiled. Can someone, who is more fancy at compiling, test that on a default centos7 vm?

  • You can assume that this project is dead. From their website: Current version of mod_fastcgi is 2.4.6. Last updated November 13th, 2007.
    – Sven
    Commented Sep 19, 2014 at 19:17
  • I rather think that fastcgi is stable since then and does not need any maintenance. Thousands of webservers running php-fpm rely on fastcgi, so I wouldn't say "dead". I guess CentOS7 is just too new and something has to be "justified" to get it working. But I'm just lost when compiling throws errors. OR: I really missed something. When it's true that fastcgi is dead, something must have replaced it ... mod_fcgid is IMHO working different at threads, isn't it?
    – sgohl
    Commented Sep 19, 2014 at 19:22

1 Answer 1


With Apache 2.4, the official module to use is mod_proxy_fcgi (tutorial) instead of the ancient mod_fastcgi. That module, as well as mod_fcgid, were third party modules.

And of course there's always nginx.

  • 2
    Thanks for your answer. I already use nginx as reverse proxy before apache, but still need to have .htaccess possibility for developers to change configs. Since i use fpm-sockets (because tcp is just impossible to manage if you have multiple pools), and mod_proxy_fcgi is only capable of sockets since 2.4.9, I had to compile httpd myself, which I actually wanted to avoid. But that's quite the only solution.
    – sgohl
    Commented Sep 23, 2014 at 9:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .