Ubuntu Server 9.04 comes with PostgreSQL 8.3 installed. This is working correctly; I am able to log in, list the databases, etc.

I have tried to follow the instructions here for installing PostGIS, including a sudo apt-get install postgis. This appeared to install version 1.3 of PostGIS okay, but then doing a locate lwpostgis.sql or locate postgis didn't return any results. Since I was unable to locate these .sql files, I was unable to continue with the installation guide.


You need to install postgresql-8.3-postgis.

The 1.3 release is quite old: You might want to install potgis 1.4 or even better 1.5 from source, but then you have to compile proj and geos first.

  • You're right; my problem was that I originally did sudo apt-get install postgis which I thought would work by automatically resolving the version I needed. In fact, it did install something but it appears it was just documentation. Passing postgresql-8.3-postgis did it – rcampbell Sep 7 '09 at 16:49

Take a look at the output of dpkg -L postgis, this should give you a list of all files contained in the package that you installed.

The locate command gets its information from a database, which is updated nightly (or manually by running sudo updatedb.

  • I ran updatedb and it now finds PostGIS files. The problem is that it does not find any of the .sql files mentioned in the installation guide. – rcampbell Sep 7 '09 at 14:05
  • The output of dpkg -L postgis returns a similar list as locate but none of the returned files are those .sql ones. Basically I just I have some docs in /usr/share/doc/postgis – rcampbell Sep 7 '09 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.