1

I have just created a user/calendar in Exchange 2010 for "Team Lunches." All employees should have editing capabilities to this calendar in order to schedule lunches with their team and for everyone to see when each team is meeting for lunch during the month.

I want to add the distribution list for all company employees as the "-User" to be granted 'Owner' Access Rights.

How do I do this in Exchange Management Shell? (without having to run a command for each employee individually or logging into a thin client and manually adding each employee to the permission list in the team lunch calendar via Outlook?)

Due to new user restrictions, I can't post images.

My command line looks like:

Add-MailboxFolderPermission -Identity teamlunch@DOMAIN.com:\calendar -User AllEmployees@DOMAIN.com -AccessRights Owner

Error looks like:

The user “AllEmployees@DOMAIN.com" is either not valid SMTP address, or there is no matching information. +CategoryInfo : NotSpecified: (0:Int32) [Add-MailboxFolderPermission], InvalidExternalUserIDException +FullyQualifiedErrorId : BFAE0537,Microsoft.Exchange.Management.StoreTasks.AddMailboxFolderPermission

Do I need to make adjustments in command line or with the distribution list in exchange management console? Any help would be much appreciated. Thanks!

0

That should work, unless you've got the SMTP address wrong for the group. Do a get-mailbox AllEmployees@DOMAIN.com | select *addresses (sorry, not in front of an exchange box to see the exact attribute for all addresses) and make sure the address is correct. If it's not, that will fail, in which case you need to find the mailbox and determine it's actual SMTP address.

  • I just found that instead of adding a permission to the mailbox you can set the permission's default setting. ..............Set-MailboxFolderPermission -Identity teamlunch@DOMAIN.com:\Calendar -User Default -AccessRights Owner................ Now employees I add into AD after I initially did that, will be able to use the Calendars no problem. – Greg Jan 20 '15 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.