2

I am trying to install a Windows 8.1 from http://modern.ie on an ESXi 5.5 server using the vSphere client. When I try to deploy the OVF template I get the following error message:

Failed to deploy OVF package: Invalid configuration for device '6'

It's unclear what device 6 is, or why it is causing a problem. Looking inside the ovf, it looks like it could be the SCSI controller, assuming I am interpreting the contents correctly.

  <Item>
    <rasd:Address>0</rasd:Address>
    <rasd:Description>SCSI Controller</rasd:Description>
    <rasd:ElementName>scsiController0</rasd:ElementName>
    <rasd:InstanceID>6</rasd:InstanceID>
    <rasd:ResourceSubType>lsilogicsas</rasd:ResourceSubType>
    <rasd:ResourceType>6</rasd:ResourceType>
  </Item>

As additional data points, I have installed a Windows 7 and Windows 8.0 VM from the same place successfully.

What is causing the error message and what can I do to install the VM?

3
  • What exact version of ESXi have you got - 8.1 is only supported in the very latest version which was only released about two weeks ago - could be the issue?
    – Chopper3
    Sep 23, 2014 at 17:05
  • @Chopper3 Are you sure about that? This vmware blog claims support was added in October 2013 at the same time as Windows 8.1 itself was released. According to the vSphere client, I have "VMware ESXi, 5.5.0, 1623387". Do you have any more information on the latest version you are talking about?
    – Burhan Ali
    Sep 23, 2014 at 17:30
  • You're right, I got my wires crossed, I recently upgraded my copy of VMWare Fusion and it was that that added 8.1 support, silly me!
    – Chopper3
    Sep 23, 2014 at 19:45

4 Answers 4

2

I first tried some different values like lsilogic and buslogic for the scsiController0 element ResourceSubType, but this kept resulting in the same error when trying to deploy.

After deleting the following section from the .ovf file I was able to deploy and boot the VM successfully. Because you altered the .ovf file, you now have to delete the .mf checksum file that comes along with it or it still won't deploy.

<Item>
  <rasd:Address>0</rasd:Address>
  <rasd:Description>SATA Controller</rasd:Description>
  <rasd:ElementName>sataController0</rasd:ElementName>
  <rasd:InstanceID>3</rasd:InstanceID>
  <rasd:ResourceSubType>vmware.sata.ahci</rasd:ResourceSubType>
  <rasd:ResourceType>20</rasd:ResourceType>
</Item>

I don't know why this is though... if anybody does, leave a comment. Despite knowing why, I hope it helps :)

And I'll just leave this tip here: if you want to edit or manage this VM via the vSphere Client, you first have to convert it to hardware version 9 or lower after deploying it. This can be done with the VMWare vCenter Converter Standalone.

2

OVF file is just descriptor to instruct your hypervisor how and what to deploy on your VM.

If you are sure error ir occurred due to above mentioned section then just delete that section. Your VM will be created without controller.

ELSE

You can add other controller like IDE etc.

0

If you haven't get information yet, this could be the answer. The culprit is vSATA could be not supported on the VCenter client but can be applied on Vcenter web client. Ironic. The item you've removed is the CD/DVD using the SATA port which should be IDE.

-1

You can just prefer this link for workaround: https://afterbyrnertech.wordpress.com/2015/06/09/vmware-failed-to-deploy-ovf-package-invalid-configuration-for-device-6/

I hope, it will help you.

1
  • 1
    Please do not just post a link, put the actual answer into your post.
    – mzhaase
    Feb 24, 2017 at 8:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .