0

I am trying to setup a Virtual Server using the Windows Server 2008 Hyper-V but each time, when I click start, after creating the Server, I get an error:

An error occurred while attempting to start the selected virtual machine(s).

'Test Server' could not initialize.

I have checked the BIOS and the settings are as follows:

1)Execute Disable Bit is enabled
2)Intel Virtualization Technology is enabled

Could someone please guide me because I cannot even start the Virtual Machine and it is frustrating. I thought that it was easy stuff :-(

Kindest Regards

  • 2
    What error does the event viewer show? – Shawn Gradwell Sep 24 '14 at 7:28
  • Hi Shawn. I had a look at the Event Viewer. I cannot see any error there... – user3391344 Sep 24 '14 at 7:48
  • what are the results of running wmic OS Get DataExecutionPrevention_Drivers from a command prompt? – Rob Moir Sep 24 '14 at 7:57
  • Result is TRUE... – user3391344 Sep 24 '14 at 11:17
1

Are the permissions on the Hyper-v .bin, .vsv, and .vhd configured properly?

I am having similar issues, go to where the vsv and .bin files are located (ex. E:\VM\\Virtual Machine\)

There should be two files there, the .vsv and .bin. Try and delete those files and start the machine again.

If you dont know where those files are, when the error comes up from trying to start the VM click the details, make note of the GUID (the crazy long number/key) search that on the server/system where your VM is being hosted.

Try http://blogs.technet.com/b/rmilne/archive/2014/01/15/hyper-v-could-not-initialize-could-not-create-or-access-saved-state-file.aspx

Edit: What are the details of the issue? Did you install an OS? What are the settings like for this VM? Was this an existing VM that you exported?

0

Regarding your query do migration to physical computer with a different processor version option and update.

Right click on VM -> Settings -> Processor -> "Migrate to a physical computer with a different processor version"] -> Enable.
  • Surely this is irrelevant as this user has created a new VM not migrating? – Rhys Evans Sep 29 '14 at 22:12
0

Very simple but does the host have enough RAM?

Also an issue I've had with Hyper-V Server 2012 R2 is does the partition with the config have enough free space to support the specified amount of RAM.

I didn't realise that the vm config partition also stores a file copy of the RAM of a VM. i.e.

if a VM has 16GB RAM it would use 16GB of storage space in the vmconfig partition - at least by default. I had initially crated a small 20GB partition to store configs not realizing this and I had a similar issue where VM's would not start.

0

I ran into a similar issue when installing core systems from powershell. Delete the vm but not the vhd file. re-create the vm and attach it to the vhd or vhdx file and you should be good to go. that's what worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.