2

I have a QLogic SANbox 5800 Fibre Channel Switch with 20 SFP ports. Out of these 20, I can use only 16. The last 4 ports are showing Operational State Down.

SANbox (admin) #> show port

    Admin       Operational  Login       Config Running     Link     Link
  Port  State       State        Status      Type   Type        State    Speed
  ----  -----       -----------  ------      ------ -------     -----    -----
  0     Online      Online       LoggedIn    GL     F           Active   8Gb/s
...
  15    Online      Online       LoggedIn    GL     F           Active   8Gb/s
  16    Online      Downed       NotLoggedIn GL     Unknown(isolated) Inactive Auto
  17    Online      Downed       NotLoggedIn GL     Unknown(isolated) Inactive Auto
  18    Online      Downed       NotLoggedIn GL     Unknown(isolated) Inactive Auto
  19    Online      Downed       NotLoggedIn GL     Unknown(isolated) Inactive Auto

How can I activate these ports? None of the connections to these ports work. I attempted to change the Operational State and the Login Status of these 4 ports, but I was unsuccessful.

I also checked the licenses and it says 20 ports are licensed but it doesn't specify which ones.

SANbox #> show version

...
       LicensedPorts       20

EDIT 1

I didn't mention that I already went through all the physical troubleshooting steps. Replaced SFPs, cables, used different ports on the connected devices, and so forth... None of those are the issue.

EDIT 2

#> show port 15

  Port Number: 15
  ------------
  AdminState       Online              PortWWN          20:0f:00:c0:dd:0d:8e:35
  AsicNumber       0                   POSTFaultCode    00000000
  AsicPort         11                  POSTStatus       Passed
  ConfigType       GL                  RunningType      Unknown
  DownstreamISL    False               MediaPartNumber  FTLF8528P3BCV
  EpConnState      None                MediaRevision    A
  EpIsoReason      NotApplicable       MediaType        800-MX-SN-S
  IOStreamGuard    Disabled            MediaVendor      DHS
  Licensed         True                MediaVendorID    00009065
  LinkSpeed        Auto                SupportedSpeeds  1, 2, 4, 8Gb/s
  LinkState        Inactive            SymbolicName     Port15
  LoginStatus      NotLoggedIn         SyncStatus       SyncLost
  MaxCredit        16                  TestFaultCode    00000000
  MediaSpeeds      2, 4, 8Gb/s         TestStatus       NeverRun
  OperationalState Offline             UpstreamISL      False
  PerfTuningMode   Normal              XmitterEnabled   True
  PortID           010f00

  ALInit             6                   LIP_F8_F7          0
  ALInitError        0                   LinkFailures       0
  BadFrames          0                   Login              5
  BBCR_FrameFailures 0                   Logout             5
  BBCR_RRDYFailures  0                   LongFramesIn       0
  Class2FramesIn     0                   LoopTimeouts       0
  Class2FramesOut    0                   LossOfSync         4
  Class2WordsIn      0                   LostFrames         0
  Class2WordsOut     0                   LostRRDYs          0
  Class3FramesIn     545327186           PrimSeqErrors      0
  Class3FramesOut    529806484           RxLinkResets       5
  Class3Toss         0                   RxOfflineSeq       0
  Class3WordsIn      259248383265        ShortFramesIn      0
  Class3WordsOut     259221106454        TotalErrors        16
  DecodeErrors       16                  TotalLinkResets    5
  EpConnects         0                   TotalLIPsRecvd     0
  FBusy              0                   TotalLIPsXmitd     8
  FlowErrors         0                   TotalOfflineSeq    15
  FReject            0                   TotalRxFrames      545327186
  InvalidCRC         0                   TotalRxWords       259248383265
  InvalidDestAddr    0                   TotalTxFrames      529806484
  LIP_AL_PD_AL_PS    0                   TotalTxWords       259221106454
  LIP_F7_AL_PS       0                   TxLinkResets       0
  LIP_F7_F7          0                   TxOfflineSeq       15
  LIP_F8_AL_PS       0

#> show port 16

  Port Number: 16
  ------------
  AdminState       Online              PortWWN          20:10:00:c0:dd:0d:8e:35
  AsicNumber       0                   POSTFaultCode    00000000
  AsicPort         13                  POSTStatus       Passed
  ConfigType       GL                  RunningType      Unknown
  DownstreamISL    False               MediaPartNumber  FTLF8528P2BNV
  EpConnState      None                MediaRevision    A
  EpIsoReason      NotLicensed         MediaType        800-MX-SN-S
  IOStreamGuard    Disabled            MediaVendor      FINISAR CORP.
  Licensed         False               MediaVendorID    00009065
  LinkSpeed        Auto                SupportedSpeeds  1, 2, 4, 8Gb/s
  LinkState        Inactive            SymbolicName     Port16
  LoginStatus      NotLoggedIn         SyncStatus       SyncLost
  MaxCredit        16                  TestFaultCode    00000000
  MediaSpeeds      2, 4, 8Gb/s         TestStatus       NeverRun
  OperationalState Downed              UpstreamISL      False
  PerfTuningMode   Normal              XmitterEnabled   False
  PortID           011000

  ALInit             0                   LIP_F8_F7          0
  ALInitError        0                   LinkFailures       0
  BadFrames          0                   Login              0
  BBCR_FrameFailures 0                   Logout             0
  BBCR_RRDYFailures  0                   LongFramesIn       0
  Class2FramesIn     0                   LoopTimeouts       0
  Class2FramesOut    0                   LossOfSync         0
  Class2WordsIn      0                   LostFrames         0
  Class2WordsOut     0                   LostRRDYs          0
  Class3FramesIn     0                   PrimSeqErrors      0
  Class3FramesOut    0                   RxLinkResets       0
  Class3Toss         0                   RxOfflineSeq       0
  Class3WordsIn      0                   ShortFramesIn      0
  Class3WordsOut     0                   TotalErrors        0
  DecodeErrors       0                   TotalLinkResets    0
  EpConnects         0                   TotalLIPsRecvd     0
  FBusy              0                   TotalLIPsXmitd     0
  FlowErrors         0                   TotalOfflineSeq    0
  FReject            0                   TotalRxFrames      0
  InvalidCRC         0                   TotalRxWords       0
  InvalidDestAddr    0                   TotalTxFrames      0
  LIP_AL_PD_AL_PS    0                   TotalTxWords       0
  LIP_F7_AL_PS       0                   TxLinkResets       0
  LIP_F7_F7          0                   TxOfflineSeq       0
  LIP_F8_AL_PS       0

SANbox #> show config port 15

  Configuration Name: default
  -------------------

  Port Number: 15
  ------------
  AdminState           Online
  LinkSpeed            Auto
  PortType             GL
  SymbolicName         Port15
  ALFairness           False
  DeviceScanEnabled    True
  ForceOfflineRSCN     False
  ARB_FF               False
  InteropCredit        0
  ExtCredit            0
  FANEnabled           True
  AutoPerfTuning       True
  MSEnabled            True
  NoClose              False
  IOStreamGuard        Auto
  PDISCPingEnabled     True

SANbox #> show config port 16

  Configuration Name: default
  -------------------

  Port Number: 16
  ------------
  AdminState           Online
  LinkSpeed            Auto
  PortType             GL
  SymbolicName         Port16
  ALFairness           False
  DeviceScanEnabled    True
  ForceOfflineRSCN     False
  ARB_FF               False
  InteropCredit        0
  ExtCredit            0
  FANEnabled           True
  AutoPerfTuning       True
  MSEnabled            True
  NoClose              False
  IOStreamGuard        Auto
  PDISCPingEnabled     True
  • Can you please show the output of a show port 15 and show port 16, as well as a show config port 15 and show config port 16? The show port command is not as verbose, and I'd like to make sure that those ports are allowed to be F ports. – Basil Sep 26 '14 at 19:45
  • @Basil I edited the question with the extra information. – slybloty Sep 29 '14 at 14:33
  • Yep, I edited my answer based on it :) – Basil Sep 29 '14 at 16:42
  • just for completion: I already was facing he same Situation in the past. Please keep in mind that the four 20GB uplink ports are also consuming licenses. So if you have 20 licenses your port 16 is unlicensed... Greetz, Sledge Callahan – Sledge Callahan Apr 15 '16 at 12:23
1

edit: removed incorrect information

So I'm seeing the EpIsoReason for port 16 is "NotLicensed". It also shows Licensed: False. I'm not sure why your show version command reported 20 licensed ports. The feature log command should display the true number of licensed ports- if that also agrees that it's 20 and these ports are still offline, then I'd open a ticket.

  • That's the Admin State which is already online. The Operational State is the one that I have issues with. I have already tried that with no success. – slybloty Sep 26 '14 at 0:32
  • Do you see light coming from whatever they're plugged into? Take a cable out, shine it on your hand. If this were a Brocade, I'd be able to use a command to tell whether it has any light to work with, but I don't know QLogic :( – Basil Sep 26 '14 at 13:24
  • I already went through all the physical troubleshooting steps. Replaced SFPs, cables, used different ports on the connected devices,... None of those are the issue. – slybloty Sep 26 '14 at 14:31
  • So you do see light coming through? Like when you point the cable at your hand, you see a light? – Basil Sep 26 '14 at 15:23
  • I've already specified that I went through all these troubleshooting steps insuring the ports are completely down. If you're referring to light coming out of the switch port, no it's not. Is you're referring to light going into the switch port, yes it is. – slybloty Sep 26 '14 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.