3

I have problem with my NAS synology, 2 days ago my storage are disconnected from the domain, and since then I am not able to connect it back. When I try connect to the domain I see this error:

enter image description here

Below I share output from tail -f /var/log/messages

Sep 25 08:53:15 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: wins_join1.c:1024 specify domain name=TEST.LOCAL
Sep 25 08:53:15 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: wins_join1.c:565 Use ads join
Sep 25 08:53:15 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: WINIGetRealm(454) can't get ads realm
Sep 25 08:53:15 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: wins_join1.c:580 ads join: use FQDN=BANYAN.LOCAL
Sep 25 08:53:15 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: SYNOWinISearchLDAP(34) net lookup ldap success.
Sep 25 08:53:15 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: wins_join1.c:591 ads join: get dc ip=192.168.175.9:389
Sep 25 08:53:16 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: get domain workgroup:TEST
Sep 25 08:53:16 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: wins_join1.c:613 ads join: get domain netbios name=TEST
Sep 25 08:53:17 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: wins_do_krb5login.c:89 kinit success
Sep 25 08:53:19 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: wins_join1.c:549 check and join failed (-1) (0)
Sep 25 08:53:19 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: wins_join1.c:549 check and join failed (-1) (1)
Sep 25 08:53:19 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: wins_join1.c:671 Use rpc join
Sep 25 08:53:19 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: wins_join1.c:681 rpc join: use NetBios name=TEST
Sep 25 08:53:22 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: WININt4Join(732) rpc join failed
Sep 25 08:53:22 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: SYNOWinJoin1(1196), Restore
Sep 25 08:53:22 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: domain.cpp:848 szStatKey:WINICheckAndJoinDomain, szStatValue:join domain fail
Sep 25 08:53:22 STORAGE entry.cgi_SYNO.Core.Directory.Domain[1].set[17639]: domain.cpp:1306 Failed to save domain/workgroup info.

Version my NAS is : DSM 5.0-4493 Update 5

Please give me some advice how I can fix it.

Regards Mick

1
  • 1
    Why aren't you running DSM 6? Did you do any windows updates recently to your DCs? Dec 3, 2016 at 4:42

3 Answers 3

1

Try to either reset the account on the NAS in the domain or delete it. Sync the AD DCs. Make sure DNS on the box defined as one of the DCs.

1
  • Yes I'm sure DNS on the box is defined as one of the DCs.
    – Mick
    Sep 25, 2014 at 11:15
-1

I had the same problem, but the source of the problem was our network printer. For some reason Synology thought that our printer is domain controller. After watching the log tail -f /var/log/messages during attempts to join the domain, I discovered our printer IP was there.

-1

Andrei is correct in that some network printers for some reason are seen by the Synology NAS units as domain controllers. Dont ask me why. Try removing the network printer, using advanced options in the NAS, and also make sure SMBv2/v3 is enabled on the server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.