2

A few days ago we got two new PowerEdge R220 servers. One is fine but the second one displays bizarre behaviour: If there's minimal load or network activity the fans spin at full speed. However once it's stressed or receives lots of network traffic the fans slow down considerably.

I updated the BIOS to the newest version but couldn't find anything to change thermal or power management.

The tests were made with random big files to create network traffic and with SuperPI to create at least a little bit of stress on a single core (and that load is sufficient!).

My questions are: what else could I try to solve this? Is this a hardware issue which means I should just call a technician?

5
  • 1
    Dell's OpenManage Server Administrator can tell you temps, RPMs, and voltages. If you haven't installed it yet it's a good idea (and the first thing Dell Support will ask) Commented Sep 25, 2014 at 12:38
  • Honestly, if these are new servers then my first communication would be with Dell, not serverfault.
    – joeqwerty
    Commented Sep 25, 2014 at 15:31
  • @joeqwerty Yeah, I think so too. Just asking for advice and looking out for options.
    – Bob
    Commented Sep 25, 2014 at 18:46
  • @charlesbridge Thanks for the tip. 2 fans at 9k RPM, one at 3k, idle. Under load: All 3 at 3k, silent. No way to change anything about it though...
    – Bob
    Commented Sep 25, 2014 at 18:49
  • Same behaviour for me as well.. Two Fans spins about 9000rpm and one about 3k. This is when no load is put on the server and with latest BIOS etc. Will give Dell a call tomorrow since this doesn´t seem right.
    – user245958
    Commented Sep 30, 2014 at 17:23

2 Answers 2

3

I managed to find a solution for this.

Go to system setup (F2), select Profile Settings and set Perfomance to custom, then make sure that: C1E = Enabled C States = Disabled.

All seems to work fine for the last couple of hours and the fans keeps the same RPM.

1
  • This was it! It's sufficient to disable C1E for my server. Thanks!
    – Bob
    Commented Oct 13, 2014 at 6:16
0

We got a new R220 (with a xeon e3-1220v3) a week ago and had similar problems with it.

Starting with the 12th Generation, a part of the thermal control is made by the iDRAC management, so you have to upgrade this firmware aswell. This fixed the problem for us.

However, we still had an issue with high CPU temperatures on this machine. Under heavy load the CPU had a constant temperature of about 85 °C, which is - in my opinion too high. The odd thing about this is, that the fans ran at 40% of their max speed.

To lower that high temperature at heavy load we configured the fan offset in the iDRAC settings to 'Low' (http://www.dell.com/support/Article/an/en/andhs1/626602/EN). Now we have ~35 °C when the CPU is idling and a maximum of ~55 °C under heavy load.

This isn't a real solution, since the fans are now constantly on a high RMP, but we hope a BIOS/iDRAC update will fix the problem!

1
  • Thanks for the answer. As far as I can tell we have the most up-to-date version of iDRAC installed though...
    – Bob
    Commented Oct 13, 2014 at 6:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .