1

Kind of in a bind here, since I heard about the bash bugs last night I decided on upgrading all off my server, not just the packages but the complete OS, it worked fine on all my servers, except my mail server, which was running Ubuntu 12.04 and I upgrade to 14.04. Everything seem running correctly but when I try to get the Zimbra service running I get the Following:

Perl API version v5.14.0 of Socket does not match v5.18.0 at /usr/share/perl/5.18/XSLoader.pm line 92. Compilation failed in require at /usr/lib/perl/5.18/Sys/Syslog.pm line 10. BEGIN failed--compilation aborted at /usr/lib/perl/5.18/Sys/Syslog.pm line 10. Compilation failed in require at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 21. BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 21. Compilation failed in require at /opt/zimbra/bin/zmcontrol line 27. BEGIN failed--compilation aborted at /opt/zimbra/bin/zmcontrol line 27.

I was kind of guessing it was problems with my Perl Version, So I downloaded perlbrew, but when I try to change the version from 5.18.0 to 5.14.0 I get the following:

Perl API version v5.14.0 of List::Util does not match v5.18.0 at /usr/share/perl/5.18/XSLoader.pm line 92. Compilation failed in require at /usr/local/share/perl/5.18.2/App/perlbrew.pm line 22. BEGIN failed--compilation aborted at /usr/local/share/perl/5.18.2/App/perlbrew.pm line 22. Compilation failed in require at /usr/local/bin/perlbrew line 6. BEGIN failed--compilation aborted at /usr/local/bin/perlbrew line 6.

Can't see my Zimbra Version, cause from zmcontrol -v I get the following:

Perl API version v5.14.0 of Socket does not match v5.18.0 at /usr/share/perl/5.18/XSLoader.pm line 92. Compilation failed in require at /usr/lib/perl/5.18/Sys/Syslog.pm line 10. BEGIN failed--compilation aborted at /usr/lib/perl/5.18/Sys/Syslog.pm line 10. Compilation failed in require at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 21. BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 21. Compilation failed in require at /opt/zimbra/bin/zmcontrol line 27. BEGIN failed--compilation aborted at /opt/zimbra/bin/zmcontrol line 27.

Quite the large bind for me, any help would be appreciated.

1

(I'm assuming you have the collaboration suite, open source edition)

Zimbra is released for specific versions of, in your case, Ubuntu. After upgrading your Ubuntu, you need to upgrade Zimbra. If you first had Zimbra for Ubuntu 12, you need to now use the installer to install for Ubuntu 14.

You need to find out which version of Zimbra you have, because as you can see on the download page, Zimbra 8.0.x is only for Ubuntu 10 and 12 and Zimbra 8.5 is for 12 and 14. You are now required to upgrade to 8.5. Look in the documentation if an upgrade path from any version directly to 8.5 is supported.

BTW, the installer can ask to verify something (don't remember what, message store or something). When you've just upgraded Ubuntu and are now installing a new Zimbra for that Ubuntu version, this feature doesn't work (because it depends on the old Ubuntu version.

Oh, and make backups first...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.