0

I upgraded my server to Ubuntu 14.04.1 LTS and now I can not seem to get my SSL certificate to work correctly.

After the upgrade I had received an error when attempting to start Apache:

AH00526: Syntax error on line 11 of /etc/apache2/sites-enabled/mywebsite-ssl

Line 11 consists of:

Options Indexes +FollowSymLinks MultiViews

I had commented this line out and then Apache would start. I went to my SquirrelMail on the server and HTTPS:// loaded just fine, but when I go to my actual website with https:// I got an Internal Server Error.

I attempted to find the problem in error logs, but nothing was recorded.

My question: Do I need to have Options Indexes +FollowSymLinks MultiView in order for my SSL to load correctly and if so, what do I do about Apache not restarting correctly when this line is not commented out?

2

With the Ubuntu update you updated the Apache version. Latest apache changed some old syntaxes such as Allow for all (although you can bring them back enabling some modules).

The Internal Error simply means that apache had a problem requesting that page. Given that you commented Options Indexes +FollowSymLinks MultiViews, I suspect it needs to follow a symlink in order to open your actual website.

The problem with your line is probably this warning:

Warning Mixing Options with a + or - with those without is not valid syntax, and is likely to cause unexpected results.

-- https://httpd.apache.org/docs/current/mod/core.html

I suggest you to change the line to:

Options Indexes FollowSymLinks MultiViews

  • Apache 2.4 has significant configuration changes compared to 2.2. Ryan, if you haven't done it yet, you should review your entire Apache configuration to make sure it's working as expected in 2.4. – Andrew Schulman Sep 26 '14 at 13:54
  • Ángel thank you for that information. I made the change, but still giving me the same error. – Ryan Sep 26 '14 at 14:00
  • @AndrewSchulman Thank you for letting me know that. I was not aware of these changes, but I'm also not very server savvy – Ryan Sep 26 '14 at 14:00
  • @Ángel I followed the URL you sent me and I replaced the Allow for all that was being used as you mentioned and the problem seems to have fixed. Thank you kindly for your help! – Ryan Sep 26 '14 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.