1

I work mainly with with Linux based servers and Sugarcrm. One of my clients has deployed his suagrcrm instance on a windows server. SugarCrm is a php application that I would normally run under a LAMP stack but can work with MS SQL etc.

Anyway the problem is that in the Sugarcrm instance there is an invoicing module that contains itemised lines. But some how the server is preventing the user from saving any more than 47 line items in a single save. This does not happen under Linux so there must be a limit on the server somewhere that limiting the POST data or query string length. Or it could be MS SQL. There are no errors showing anywhere in the logs and I have increased all the settings in the php.ini file so it cant be a php problem.

Anybody have anybody have any idea's what could be causing this?

The specs are as follows

Dell R520 Server

Windows Server 2012 R2

2x Intel Xeon E5-2430 v2 @ 2.5ghz

32GB Ram

1x Raid 1 160gb hdd array 15k SAS drives

2x Raid5 560gb hdd array 15k SAS drives

Webserver Configuration is IIS 8.5

PHP 5.4.24

MS SQL Server 2014

MS SQL Server 2012 Native Client

0

Are you able to capture the request headers for one of these requests and do you have the exact HTTP response code?

If you are concerned that POST data might be too big for the server setting you can increase it in your web.config. You can see full request limit documentation here.

<system.webServer>
  <security>
    <requestFiltering>
      <requestLimits maxAllowedContentLength="[new size in bytes]" />
    </requestFiltering>
  </security>
</system.webServer>
  • I can see the headers in firebug and the response code is just a 301 because its meant to redirect after a save so therefore the save is not failing its just not getting passed all the data. – Andy Sep 26 '14 at 16:31
  • Ok, can you see the value of the Content-Length header in the request that includes your POST data? Is it larger than the max allowed content length set on your server? – squillman Sep 26 '14 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.