0

I recently tried installing HHVM on my Centos VPS today without luck. I then tried to update my VPS and received the following errors below. I'm quite new to the command line so I don't have a clue as to what I did (unfortunately). Can anyone point me in the right direction?

sudo yum update
Loaded plugins: fastestmirror
Determining fastest mirrors
epel/metalink                                            | 9.4 kB     00:00     
 * base: centos.mirror.constant.com
 * epel: mirror.es.its.nyu.edu
 * extras: centos.mirror.constant.com
 * updates: centos.mirror.constant.com
 * webtatic: us-east.repo.webtatic.com
base                                                     | 3.7 kB     00:00     
base/primary_db                                          | 4.4 MB     00:00     
epel                                                     | 4.4 kB     00:00     
epel/primary_db                                          | 6.3 MB     00:00     
extras                                                   | 3.3 kB     00:00     
extras/primary_db                                        |  19 kB     00:00     
hhvm                                                     | 3.0 kB     00:00     
hhvm/primary_db                                          |  66 kB     00:00     
mariadb                                                  | 1.9 kB     00:00     
mariadb/primary_db                                       |  18 kB     00:00     
updates                                                  | 3.4 kB     00:00     
updates/primary_db                                       | 5.3 MB     00:00     
vz-base                                                  |  951 B     00:00     
vz-base/primary                                          | 1.3 kB     00:00     
vz-base                                                                     3/3
vz-updates                                               |  951 B     00:00     
vz-updates/primary                                       | 2.2 kB     00:00     
vz-updates                                                                  8/8
webtatic                                                 | 3.6 kB     00:00     
webtatic/primary_db                                      | 216 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rpm.x86_64 0:4.8.0-37.el6 will be updated
---> Package rpm.x86_64 0:4.9.1.3-6.el6 will be an update
--> Processing Dependency: libdb-5.2.so()(64bit) for package: rpm-4.9.1.3-6.el6.x86_64
---> Package rpm-libs.x86_64 0:4.8.0-37.el6 will be updated
--> Processing Dependency: librpm.so.1()(64bit) for package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64
--> Processing Dependency: librpm.so.1()(64bit) for package: 1:net-snmp-5.5-49.el6_5.3.x86_64
--> Processing Dependency: librpmio.so.1()(64bit) for package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64
--> Processing Dependency: librpmio.so.1()(64bit) for package: 1:net-snmp-5.5-49.el6_5.3.x86_64
---> Package rpm-libs.x86_64 0:4.9.1.3-6.el6 will be an update
---> Package rpm-python.x86_64 0:4.8.0-37.el6 will be updated
---> Package rpm-python.x86_64 0:4.9.1.3-6.el6 will be an update
--> Processing Dependency: librpmbuild.so.2()(64bit) for package: rpm-python-4.9.1.3-6.el6.x86_64
--> Processing Dependency: librpmsign.so.0()(64bit) for package: rpm-python-4.9.1.3-6.el6.x86_64
--> Running transaction check
---> Package libdb.x86_64 0:5.2.36-1.el6 will be installed
---> Package rpm-build-libs.x86_64 0:4.9.1.3-6.el6 will be installed
---> Package rpm-libs.x86_64 0:4.8.0-37.el6 will be updated
--> Processing Dependency: librpm.so.1()(64bit) for package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64
--> Processing Dependency: librpm.so.1()(64bit) for package: 1:net-snmp-5.5-49.el6_5.3.x86_64
--> Processing Dependency: librpmio.so.1()(64bit) for package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64
--> Processing Dependency: librpmio.so.1()(64bit) for package: 1:net-snmp-5.5-49.el6_5.3.x86_64
--> Finished Dependency Resolution
Error: Package: 1:net-snmp-5.5-49.el6_5.3.x86_64 (@updates)
           Requires: librpm.so.1()(64bit)
           Removing: rpm-libs-4.8.0-37.el6.x86_64 (installed)
               librpm.so.1()(64bit)
           Updated By: rpm-libs-4.9.1.3-6.el6.x86_64 (hhvm)
               Not found
Error: Package: 1:net-snmp-5.5-49.el6_5.3.x86_64 (@updates)
           Requires: librpmio.so.1()(64bit)
           Removing: rpm-libs-4.8.0-37.el6.x86_64 (installed)
               librpmio.so.1()(64bit)
           Updated By: rpm-libs-4.9.1.3-6.el6.x86_64 (hhvm)
               Not found
Error: Package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64 (@updates)
           Requires: librpmio.so.1()(64bit)
           Removing: rpm-libs-4.8.0-37.el6.x86_64 (installed)
               librpmio.so.1()(64bit)
           Updated By: rpm-libs-4.9.1.3-6.el6.x86_64 (hhvm)
               Not found
Error: Package: 1:net-snmp-libs-5.5-49.el6_5.3.x86_64 (@updates)
           Requires: librpm.so.1()(64bit)
           Removing: rpm-libs-4.8.0-37.el6.x86_64 (installed)
               librpm.so.1()(64bit)
           Updated By: rpm-libs-4.9.1.3-6.el6.x86_64 (hhvm)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
0

Removing hhvm.repo from etc/yum.repos.d solved it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.