9

I'm trying to run the mpm-itk module on CentOS. Unfortunately, that requires apache 2.4.7 while the current version on centos is 2.4.6, so compiling the module is out of the picture.

Alternatively, centos now offers the httpd-itk package which creates another apache binary (/usr/sbin/httpd.itk).

As per this article, one can set the HTTPD parameter in /etc/sysconfig/httpd to run apache through itk. However that is no longer the case with CentOS 7. Instead httpd uses /etc/httpd/conf.modules.d/00-mpm.conf to load whichever module you want. Except itk is not a module in this case but an executable!

How do I switch from using httpd at httpd.itk in this case?

Thanks!

3
  • I have the same problem. httpd is 2.4.7, httpd-itk is 2.2.x which does not match. So itk is actually not working for CentOS 7 :(
    – user263811
    Jan 7, 2015 at 15:02
  • Did anybody install itk on CentOS 7 ?
    – user268755
    Feb 4, 2015 at 21:17
  • Nope. I gave up on that route.
    – sdragnev
    Feb 9, 2015 at 19:27

1 Answer 1

7

For those still looking for a solution and/or getting AH00534: httpd: Configuration error: No MPM loaded when attempting to use ITK:

To use ITK, you should now:

  • yum install httpd httpd-itk
  • Edit /etc/httpd/conf.modules.d/00-mpm-itk.conf
  • Uncomment the #LoadModule line by removing the leading #
  • Do not comment out the LoadModule mpm_prefork_module line in 00-mpm.conf (this is where we got caught out)
  • Restart httpd

You should now see multiple httpd processes - this is different from CentOS 6 where processes ran as httpd.itk; if you access one that's configured to use a different user, you should see it switch to run as that user.

(Note also that there was also previously a bug with the httpd-itk, as filed on RedHat's Bugzilla: Bug 1188159 - Version mismatch between httpd-itk and httpd which prevented the use of httpd-itk)

2
  • Is this supposed to work on Centos 7? I'm trying to execute yum install httpd-itk and I'm getting the message No package httpd-itk available.
    – Mirrana
    Mar 30, 2016 at 0:29
  • @agent154 httpd-itk is in EPEL. Dec 4, 2016 at 23:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.