3

In yesterday, i install a windows server 2008 r2 and enable remote desktop on it. Then from my ubuntu desktop by remmina i could connect ok.

Today, i cannot connect to it by remmina. I check its connectivity by pinging it, That's OK, and also remote desktop is enable.

I search about it too much, and test any changes like change Advanced > security to other modes, Remove ~/.freerdp/unknown_host and ...

How to debug connection problem step by step? and What is the exact problem?

NOTE: I can connect to windows 2008 from another windows(7) client by mstsc without any problem.

3

Maybe its something with the RDP with NLA Option?

What did you Select on your WIndows Server at SYSTEM PROPERTIES --> REMOTE --> REMOTE DESKTOP ?

Try to Select "Allow connections from computers running any version of Remote Desktop" if actually "allow connections only from computers running Remote Desktop with Network Level Authentication" is selected.

But this is just a thought. Don't know if this is the solution.

1
  • Yea I exactly select the option you mentioned.
    – shgnInc
    Sep 29 '14 at 12:38
1

The problem was base on target network configurations.

The target network was configured for 2 IP address with 2 gateway which the gateways make wrong routing to target.

1
  • How did you find this out? I'm having a similar "I won't connect and I won't tell you why" error - how did you debug?
    – Hippyjim
    Nov 4 '15 at 9:33
0

It may be that the trusted host IP has changed. Assuming a safe and secure network environment (does this exist?), one can check by

cd ~/.freerdp ;
mv known_hosts hosts_old

and then retrying the connection to the host (and confirming the new trusted host; note that if this doesn't work, it would be best to move "hosts_old" back).

1
  • 1
    Removing all known hosts isn't a good idea. It also isn't a good idea to remove an entry from known hosts based on a guess about what the problem might be. You should only remove an entry from known hosts if you know why it is no longer valid.
    – kasperd
    Nov 26 '15 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.