0

I just got a PositiveSSL cert from Comodo and then followed the steps here

http://billpatrianakos.me/blog/2014/04/04/installing-comodo-positive-ssl-certs-on-apache-and-openssl/

to setup Apache. When I created the CSR I had specified mydomain.com as the FQDN. However, when I restart Apache and examine the error logs I see the message

RSA certificate configured for example.com:443 does NOT include an ID which matches the server name

openssl x509 -in server.crt -noout -subject

gives me the output

subject = /OU=Domain Control Vaidated/OU=PositiveSSL/CN=example.com

My apache2.conf file contains

<VirtualHost ip:443>
ServerAdmin admin@example.com
DocumentRoot /var/www/html/
ServerName example.com
ServerAlias www.example.com
SSLEngine on
SSLCertificateFile /etc/apache2/ssl/example.com.crt
SSLCertificateKeyFile /etc/apache2/ssl/example.com.key
SSLCACertificateFile /etc/apache2/ssl/example.com.cer

For good measure I have tried concatenating (in that order)

COMODORSADomainVaidationSecureServerCA.crt COMODORSAAddTrustCA.crt

on their own and also with (last) AddTrustExternalCARoot.crt.

It makes no difference. I have to admit that I am fumbling in the dark here. I'd be most grateful to anyone who might be able to help here.

7
  • You may wish to consider not redacting your domain name, and posting the certificate (not the private key!) here; it'll all help with diagnosing the problem.
    – MadHatter
    Sep 29 '14 at 14:19
  • I thought the etiquette here required redaction. You mean I post the contents of the .crt file?
    – DroidOS
    Sep 29 '14 at 14:29
  • <grin> far from it - more data is always welcome, though there is debate about how much is required. Yes, I do mean post the contents of the .crt file - SSL certificates are not a private matter, given as they are to every single person who ever makes an SSL connection to your server.
    – MadHatter
    Sep 29 '14 at 14:34
  • Thanks. As it turns out I managed to fix this. I had added the SSL cert info to my /etc/apache2/apache2.conf file. I went and added the same info to the /etc/apache2/sites-enabled/default-ssl.conf file, restarted Apache and it all worked. I should explain that a while ago I had added <VirtualHost IP:443(& 80)> directive to the apache2.conf file to keep out someone out there on BigDaddy who was merrily pointing his garbage domain to my IP.
    – DroidOS
    Sep 29 '14 at 14:41
  • @MadHatter I meant to add - by and large I get these things working by trial & error so if you can explain why the setup I now have works I would much appreciate it (and vote up your answer :-)
    – DroidOS
    Sep 29 '14 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.