1

I have an issue where the bind9 service aka named in my ubuntu system is starting up before my openvpn service.

When this happens, the network interface that openvpn creates (tun0) is not found by bind upon its startup and thus doesn't include it in the list of adapters to bind to. I have to restart bind after the system has booted up and then everything works.

I've tried renaming the openvpn service to 0openvpn in /etc/init.d/. I've also tried renaming the bind service in /etc/rc0.d/ from K85bind9 to K20bind9 and K99bind9, I read somewhere that changing the number up or down can affect the order in which it starts services.

These methods did not work, I've reverted those changes since.

I know this is a basic question/problem but I believe I've been looking up the wrong terms or something, how do you re-order/delay bind9's starting up so that it starts after openvpn has initialized?

Thanks

  • Did you ever rename the OpenVPN service to S0openvpn instead of 0openvpn? – Janne Pikkarainen Oct 1 '14 at 7:32
1

If your issue is the service starting in a different order you should change the number in the other set of scripts, I mean, not the KXXscript, but the SXXscript since the scripts starting with S affect the start of said services. The K are related with the stop (Kill) of services, so basically you changed the order in which bind9 and openvpn are stopped, but not the order in which they start.

  • changing the names in rc2.d that started with 'S' did the trick. thanks. – RCG Oct 1 '14 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.