0

I use Linux on my computer at work and the server uses Novell. I am friendly with the IT staff in a "don't bother us, and we won't bother you" kind of way, and I can usually fix my problems myself with a bit of googling.

However, there is one problem that I can't seem to understand how to fix. This is what I use for mounting a Novell server:

ncpmount -A ... -S ... -U ... -u ... -P ... -o codepage=cp850,iocharset=utf8 /mnt/novell

It works fine, except when a filename has accented characters in it. Then I cannot see the file at all. This is causing me headaches because coworkers will save a file to the server with accented characters and I'll have to use a Windows virtual machine to rename it.

I googled for a while and found this old Debian bug report from 2002:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=145654

which says the problem comes not from ncpfs but from the Kernel. There is also a short thread on the Linux Kernel mailing list from the same time:

https://lkml.org/lkml/2002/5/7/235

but I'm not technical enough to understand if the problem is fixable, and what I can try. Any help appreciated. Thanks!

-1

shot in the dark,depends on the environment.

If running OES or better with NSS:

If you can get IT to turn on CIFS for the NSS volume the share lives on, you can eliminate NCPmount and just connect using SMB. Works the same from an end user standpoint, but you lose access for the NCP functions like Salvage/Purge, your shares will be available and if you write something, it is owned by you in NSS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.