0

I have a Terminal Server setup on Windows server 2008 R2.

I am trying to log in to it with RDP, using the local admin account. (Not the domain admin) I have placed the local admin in the remote desktop users group, but I am still getting the following message trying to log in:

To log on to this computer, you must be granted the Allow log on through Terminal Services right. By default, members of the Remote Desktop Users group have this right. If you are not a member of the Remote Desktop Users group that has this right, or if the Remote Desktop Users group does not have this right, you must be granted this manually.

Any help will be greatly appreciated.

Notes:

I found a temporary solution; Installign LogMeIn, this logged me in to the local admin account, remotely without problems

  • The server IS part of a domain.
  • Domain users placed in RDP users group can successfully login without any problem.
  • I have placed the local admin, inside the local RDP group. (And it is not working)
  • The TS server is a 'vigrin' system
  • The AD/DNS are not 'virgin'.
  • There are NO restricted groups, yet.
  • I am using \Administrator as a login (This avoids domain logins)
  • Also tried Computername\Administrator and .\Administrator
  • Domain functionality level is Windows Server 2008 R2
  • Cannot alter group policy: "Allow log on through Remote Desktop Services" (the add button is greyed out) +

+: A following note on the group policy; It states that "This setting is not compatible with computers running Windows 2000 SP1 or earlier. Apply group policy objects containing this setting only to computers running a later version of the OS.

1

My suspicion is that this is disabled through group policy. (The greyed out "Allow log on through Remote Desktop Services" button in particular suggests this.) This policy is defined in

Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> User Rights Assignment -> Deny Log On Through Terminal Services

If so, you'll have to either change the policy or use a different local account with administrative privileges.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.