20

I have a little problem with my apache conf. When I read the error log, here is what I can see:

[client xxx.xxx.xx.xx] AH01964: Connection to child 1 established (server www.mywebsite.com:443)
[client xxx.xxx.xx.xx] AH01964: Connection to child 6 established (server www.mywebsite.com:443)
[client xxx.xxx.xx.xx] AH01964: Connection to child 10 established (server www.mywebsite.com:443)
[client xxx.xxx.xx.xx] AH01964: Connection to child 15 established (server www.mywebsite.com:443)
[client xxx.xxx.xx.xx] AH01964: Connection to child 18 established (server www.mywebsite.com:443)
(70014)End of file found: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.
(70014)End of file found: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.
(70014)End of file found: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.
(70014)End of file found: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.
(70014)End of file found: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.

And sometimes, this one:

 (70007)The timeout specified has expired: [client xxx.xxx.xx.xx] AH01991: SSL input filter read failed.

I don't know actually ... so my website is full HTTP, except two page in HTTPS. So here is my virtualHost:

<VirtualHost *:80>
    ServerName mywebsite.com
    Redirect permanent / http://www.mywebsite.com/
</VirtualHost>
<VirtualHost *:80>
    ServerName www.mywebsite.com
    ServerAlias img.mywebsite.com
    ServerAdmin xxx
    DocumentRoot /home/mywebsite/www/public
    <Directory /home/mywebsite/www/>
        Options Indexes Multiviews FollowSymlinks
        AllowOverride All
        Require all granted
        ErrorDocument 403 http://www.google.com/
    </Directory>
    <Directory /home/mywebsite/www/public/resource/private/>
        Require all denied
        ErrorDocument 403 http://www.mywebsite.com/
    </Directory>
    <Location "/robots.txt">
            Require all granted
    </Location>

    LogLevel info
    ErrorLog ${APACHE_LOG_DIR}/mywebsite_error.log
    CustomLog ${APACHE_LOG_DIR}/mywebsite_access.log combined
</VirtualHost>
<IfModule mod_ssl.c>
    <VirtualHost *:443>
        ServerName www.mywebsite.com
        DocumentRoot /home/mywebsite/www/public
            <Directory /home/mywebsite/www/>
                Options Indexes FollowSymlinks Multiviews
                AllowOverride all
                Require all granted
            </Directory>
        LogLevel info
        ErrorLog ${APACHE_LOG_DIR}/mywebsite_error.log
        CustomLog ${APACHE_LOG_DIR}/mywebsite_access.log combined

        SSLEngine on
        SSLCertificateFile ./mywebsite.crt
        SSLCertificateKeyFile ./mywebsite.key
        SSLCertificateChainFile ./intermediate.crt
    </VirtualHost>
</IfModule>

So, where I've done a mistake? I can't find it out ... Can you help me?

thank :)

1
  • I'm having the same problem in Apache 2.4.7. It's not a question of SNI support. Nor is "just lower the log level" a real answer :) – Iguananaut Aug 25 '16 at 13:43
10

I read that Apache doesn't support SSL on name-based virtual host, only on IP based Virtual Hosts. So I changed it:

 <VirtualHost *:443>

by:

 <VirtualHost 192.168.1.1:443>

For now, it seems to work, I don't know if it's the good solution, but I don't have any error ...

6
  • 1
    Indeed, the Apache recommendations and sample configuration is here. – Ben Feb 9 '15 at 19:01
  • 11
    The same problem in apache-2.4 is not fixed by this solution :( – mircealungu May 15 '15 at 15:26
  • You may need to add multiple IPs if you have more than one hostname you're trying to serve over SSL. – quickshiftin Jun 26 '15 at 19:36
  • 2
    Apache is supposed to support SSL on multiple VirtualHosts using the same IP "using 2.2.12 or later web server, built with 0.9.8j or later OpenSSL" with clients newer than IE8/WinXP. This is called SNI. There's discussion here. I have it working, but these pesky log messages are everywhere! – partofthething Nov 17 '15 at 6:09
  • It's not working for me. – QkiZ Jan 26 '16 at 11:26
1

One more requirement is add the following line to the end of your VirtualHost SSL port 443 directives blocks

SetEnv nokeepalive ssl-unclean-shutdown

As stated here:

1
0

for me ridiculously simple solution for this error as follows (this error shown up after adding files/folders as root):

chown www-data: /var/www -R
chmod 755 /var/www -R
0

I had the same error and for me the reason was that <VirtualHost *:443> has been defined in 2 different config files in Apache. Once in the SSL.conf and the second time in the .conf file I was adding. Once I removed reference to <VirtualHost *:443> (with its closing argument) from my second file everything worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.