1

So I have successfully cloned my existing TFS 2010 production environment onto new hardware (and software) and it is running TFS 2013. Everything appears to be working just fine.

I notice however that when I run the TFS 2013 Best Practices Analyzer it is trying to perform a health check on my old application tier as well as my new one.

The message is:

The application tier was not scanned The application tier "old_apptier_server" has not connected to Team Foundation Server during the past 72 hours.

Before running any TFS configuration on any of the restored databases I ran ChangeServerId and RemapDBs. When I look in the admin console on the new and old tiers I see no mention of the other tier and so they appear to be isolated except for this.

Why would the Best Practices Analyzer be trying to analyze my old app tier and how can I fix it?

UPDATE:

I notice a checkbox in the Application Tier node of the TFS admin console that reads:

Filter out machines that have not connected in more than 3 days

If I uncheck it then my TFS 2010 server shows up so I am guessing that this is why BPA picks it up. Is this normal? Is it problematic? How can I remove the old entry? I cannot seemto find too much info on this checkbox.

  • I too have the same issue after a migration from TFS 2010 to TFS 2013 on new hardware. We migrated back in march and have recently upgraded to TFS 2013.3 We're not seeing any issues in day to day use but it would be nice if we could understand the issue. – James Reed Oct 8 '14 at 10:44
  • Microsoft is kinda hazy about some things. I found this: msdn.microsoft.com/en-us/library/dd793167.aspx which mentions the message. – Mike Cheel Oct 8 '14 at 12:35
0

This is by design and is not an issue. Once the old server has not connected for more than 30 days the BPA will no longer check it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.