2

Summary

My standalone physical server is running Server 2012 R2 Foundation. Two separate backup schedules exist, both using Windows Server Backup. I'm getting VSS errors from the DHCP Jet Writer during a weekly backup created with the WBADMIN command, but not during the two daily backups run from the schedule created with the Windows Server Backup GUI.

Details

Backup Schedule #1

  • This is the backup that triggers errors
  • Runs every Sunday at 12:00 AM
  • Backup is written to one of three rotated USB 3.0 drives
  • Backup is created by running WBADMIN from a PowerShell script. The command is:

    wbadmin start backup -backuptarget:"\\?\Volume{86997494-eb2a-11e3-80c1-d4ae52d397d7}\" -allCritical -systemState -vssFull --% -include:"C:","E:" -quiet
    

Backup Schedule #2

  • This backup does not trigger errors
  • Runs daily at 12:30 PM and 11:00 PM
  • Backup is written to a internal hard disk dedicated for backups
  • Backup is created by the Scheduled Backup through the WSB GUI

Problem

  • Only the weekly backup has problems
  • It completes successfully (Event ID 14 The backup operation has completed is recorded in the Microsoft-Windows-Backup/Operational log)
  • Many VSS/ESENT errors are logged immediately after the backup begins.
  • These events are logged every time this backup runs when scheduled, and have been logged since the server was installed 4 months ago
  • The server is restarted regularly (at least monthly), yet there's never been a Sunday the errors aren't logged
  • Following are the events recorded in the Application event log:

Event ID 2002 (Source ESENT):

svchost (1860) Shadow copy instance 15 encountered error -2403 on freeze.

Event ID 12290 (Source VSS):

Volume Shadow Copy Service warning: ESENT ERROR {be9ac81e-3619-421f-920f-4c6fea9e93ad} Dhcp Jet Writer: -2403.  hr = 0x00000000, The operation completed successfully.

Operation:
   OnFreeze event
   Freeze Event

Context:
   Execution Context: Jet Writer
   Writer Class Id: {be9ac81e-3619-421f-920f-4c6fea9e93ad}
   Writer Name: Dhcp Jet Writer
   Execution Context: Writer
   Writer Class Id: {be9ac81e-3619-421f-920f-4c6fea9e93ad}
   Writer Name: Dhcp Jet Writer
   Writer Instance ID: {d25a80e6-7314-4c56-98f4-7f9ee9500b6a}

Event ID 8229 (Source VSS):

A VSS writer has rejected an event with error 0x800423f3, The writer experienced a transient error.  If the backup process is retried,
the error may not reoccur.
. Changes that the writer made to the writer components while handling the event will not be available to the requester. Check the event log for related events from the application hosting the VSS writer. 

Operation:
   Freeze Event

Context:
   Execution Context: Writer
   Writer Class Id: {be9ac81e-3619-421f-920f-4c6fea9e93ad}
   Writer Name: Dhcp Jet Writer
   Writer Instance ID: {d25a80e6-7314-4c56-98f4-7f9ee9500b6a}
   Command Line: C:\Windows\system32\svchost.exe -k DHCPServer
   Process ID: 1860

Event ID 2007 (Source ESENT):

svchost (1860) Shadow copy instance 15 aborted.

Event ID 16389 (Source SPP):

Writer Dhcp Jet Writer experienced retryable error during shadow copy creation. Retrying...  More info: .

What I've Tried

  1. I ran vssadmin list writers. All writers report stable and no errors. (I've not yet had a chance to run this immediately after the Sunday 12:00 AM backup, however.)
  2. I've run the Sunday 12:00 AM backup manually. No errors are reported.
  3. I've done lots of Googling.
    • I've of course found this SF question, but it applies to Server 2003.
    • This blog post suggests restarting the DHCP service, but I can't see how that helps. The server gets restarted at least monthly but I've had this problem for the life of the server (4 months)
    • I reviewed TechNet article Troubleshoot VSS issues that occur with Windows Server Backup (WBADMIN) without luck
    • I looked at this article addressing a similar issue with Symantec Backup Exec, but my symptoms are different and I'm not at all excited about enabling a shadow copy schedule on my C: volume.

Notes

  • The backups run 40 minutes at most and overlap is not the problem.
  • No other tasks are scheduled to run any time close to 12:00 AM Sunday, with exception of the 11:00 PM backup, but as noted, that backup is never done later than 11:40 PM
  • The event logs are otherwise clean (well, as clean as a Windows Server's event log can be!)

What else can I try? I'll post any additional info that's needed.

  • What does the --% parameter do? Also, do you change the volume ID for the USB drive when you rotate it? Or...? – BlueCompute Oct 9 '14 at 10:29
  • @BlueCompute --% tells PowerShell to stop parsing the command so it doesn't return an error when commas appear in the -include or -exclude parameters. The disk GUID is changed when the USB drive is rotated. I didn't include the full script as it's over 100 lines of code. – I say Reinstate Monica Oct 9 '14 at 11:37
  • Ah, no worries, I missed the bit about it being run in powershell... – BlueCompute Oct 9 '14 at 11:46
0

I resolved this by moving the start time forward 30 minutes for the weekly backup that was giving me problems. I looked diligently for some process that was running that would conflict with the original 12:00 AM start time but was unable to find one, yet the only conclusion I can draw is that something else was preventing the DHCP VSS writer from functioning when the backup started.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.