1

I'm facing an issue, here is the context:

  • 1 PDCe (192.168.1.3 and Hyper-V virtualized) is set as NTP server, its source for time is VM IC Time Synchronization.

  • 1 DC (Hyper-V virtualized) is retrieving NTP informations from PDC, mentioned above, configured with: w32tm /config /manualpeerlist:192.168.1.3 /syncfromflags:domhier /reliable:yes /update

The problem is that there's a big delay between PDCe and DC (approx. 22secs, seen with w32tm /monitor, delay is called offset).

How can I manage to fix this annoying delay?

1
  1. Don't use a manual peer list if you're syncing from the domain hierarchy.

  2. Sync your PDCe from an external time source - not the Hyper-V host.

  3. Disable Hyper-V host time sync for your virtual DCs.

| improve this answer | |
  • Wrong on 3 - on 2012 R2 at least.... 2012 yes, 2012 r2 leave it running. It is smart enough to integrate well and it is needed for boot scenarios. – TomTom Oct 10 '14 at 11:18
  • @TomTom do you have a link? I'm sure you're right, but the "Virtualizing Domain Controllers" TechNet article doesn't mention this. – MDMarra Oct 10 '14 at 12:33
  • 2012 r2 added a great deal of new features to allow domain controllers to just work. Including ability to use snapshots with automatic updating of the dc etc. time service blogs.msdn.com/b/virtual_pc_guy/archive/2010/11/19/… is quite clear to never disable time service ;) – TomTom Oct 10 '14 at 12:40
  • 1
    For virtual machines that are configured as domain controllers, it is recommended that you disable time synchronization between the host system and guest operating system acting as a domain controller. - From this article dated August 2013. So it isn't clear at all, Microsoft appears to have several conflicting recommendations. technet.microsoft.com/en-us/library/… – Zoredache Oct 10 '14 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.