How can I manage the system files on a filer or vFiler in Netapp? There are a couple of really important system files in every filer that it's really only feasible to manage by hand. While there are sometimes tools to manage them from a GUI, it's inconsistent. I find myself managing the following things by hand the most:

  • /etc/exports
  • /etc/group
  • /etc/passwd
  • /etc/cifs_homedir.cfg
  • /etc/rc (real filers only)
  • /etc/hosts
  • /etc/quotas
  • I find we end up hand editing /etc/quotas as well. – Sobrique Oct 14 '14 at 9:30
  • Yeah, that's a good one. – Basil Oct 14 '14 at 12:58

There are a few ways to edit these systems. You can mount them using NFS or CIFS, or you can use commands on the main filer. You could also use FTP. Either of the mount options relies on the protocol (CIFS or NFS) being enabled.


You can mount the /etc directory on any NFS client and have access to all the files. The only restriction that matters is that you have to be root on the system you're using. If you're not the admin for the server, you can still mount the directory, but you can't modify things (at least not without making things less secure). If you have a properly configured LDAP environment, this may not be an issue.


CIFS is another way to get to /etc. When you set up the CIFS daemon on Netapp, you have the opportunity to create a local administrator account- it's a good idea. When you try to browse to \\filer\etc$\, you'll be prompted for a login. Use the username filer\administrator and the password you set up during the cifs setup command.

Filer commands

Of course, sometimes you might need to use the native command line sometimes for this. Unfortunately, the primary tools provided for this are a little kludgy: rdfile and wrfile will allow you to read and write to any location, however every time the system decides to spit something out into the terminal, it'll mess up the spacing of your line. Any time this happens, it doesn't actually make it into your file, and you can press control-r to get the line you're working on back from the beginning.

If you can't mount /etc/, it's usually because you aren't on the same network as a vFiler. One way to get around this restriction is to use ndmpcopy to copy the file you need to edit back to a filer that is on the same network, where you could mount a volume and edit the file in an editor in Windows or Unix/Mac.


This is much riskier, but if you have no other option, you can use FTP to access any data on the filer. There's an option to allow complete access to the filer through FTP that defaults to off. I'd recommend leaving that off, and instead, while you're doing your work, allow FTP access to just /etc. Remember that this is FTP- passwords are sent in plaintext.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.