1

I installed libtiff by command yum install libtiff-devel.x86_64 which installed ver 3.9.4.

[anthony@server ~]$ sudo yum list installed | grep "libtiff" libtiff.x86_64 3.9.4-10.el6_5 @updates libtiff-devel.x86_64 3.9.4-10.el6_5 @updates

Question

However, I wish to have version 4.0.3. How can I get the version I want?

What I've tried

I tried adding these rpm's I found for 4.0.3 http://rpmfind.net/linux/rpm2html/search.php?query=libtiff but when I try, I get an error saying failed dependencies:

[anthony@server ~]$ rpm -Uvh ftp://rpmfind.net/linux/sourceforge/o/os/osolinux/update/RPMS.l/libtiff-4.0.3-17_Oso.x86_64.rpm
Retrieving ftp://rpmfind.net/linux/sourceforge/o/os/osolinux/update/RPMS.l/libtiff-4.0.3-17_Oso.x86_64.rpm
error: Failed dependencies:
    libc.so.6(GLIBC_2.14)(64bit) is needed by libtiff-4.0.3-17_Oso.x86_64
    libjbig.so.2.0()(64bit) is needed by libtiff-4.0.3-17_Oso.x86_64
    liblzma.so.5()(64bit) is needed by libtiff-4.0.3-17_Oso.x86_64
    libtiff.so.3()(64bit) is needed by (installed) wxGTK-2.8.12-1.el6.centos.x86_64
    libtiff.so.3()(64bit) is needed by (installed) wxGTK-gl-2.8.12-1.el6.centos.x86_64
    libtiff.so.3()(64bit) is needed by (installed) qt-x11-1:4.6.2-28.el6_5.x86_64
    libtiff.so.3()(64bit) is needed by (installed) gtk2-2.20.1-4.el6.x86_64
    libtiff.so.3()(64bit) is needed by (installed) opencv-2.0.0-12.el6.x86_64
    libtiff.so.3()(64bit) is needed by (installed) ImageMagick-6.5.4.7-7.el6_5.x86_64
    libtiff.so.3()(64bit) is needed by (installed) libtiff-devel-3.9.4-10.el6_5.x86_64
    libtiff.so.3()(64bit) is needed by (installed) cups-libs-1:1.4.2-52.el6_5.2.x86_64
    libtiffxx.so.3()(64bit) is needed by (installed) libtiff-devel-3.9.4-10.el6_5.x86_64
    libtiff = 3.9.4-10.el6_5 is needed by (installed) libtiff-devel-3.9.4-10.el6_5.x86_64
0

On CentOS 6 you will need to build and install it from source, or make your own packages.

If you can upgrade to CentOS 7 you can get 4.0.3 from the CentOS repositories.

5
  • I thought this page (rpmfind.net/linux/rpm2html/search.php?query=libtiff) suggested that there are certain RPMs i can get which will let me do it.. – Anthony Oct 12 '14 at 3:52
  • how can I uninstall the current 3.9.4 version before I start building it from scratch? – Anthony Oct 12 '14 at 3:53
  • yum remove libtiff – Gene Oct 12 '14 at 4:00
  • building it from source is a nightmare. it has so many dependencies. – Anthony Oct 12 '14 at 4:17
  • CentOS isn't geared towards the latest and greatest, especially when you're running the previous release. If you can upgrade to CentOS 7 or run Debian or Ubuntu Server you'll have an easier time of it. – Gene Oct 12 '14 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.