On my system partition I have a folder which cannot be deleted. This folder has been created by restoring files from an Acronis TrueImage backup.

The error message says:

Error 0x80070570: The file or directory is corrupted and unreadable.

I already tried running chkdsk /r /f when booting several times but the problem persists.

Are there any other utilities or chkdsk options which I could try to fix this problem?

  • 1
    Anyways in my case just right clicking on the drive and running check and repair from Windows GUI worked for me. It's Windows 10. Leaving a comment in case somebody might find it useful.
    – xji
    Nov 2, 2015 at 14:37
  • Take any file, rename it to the same name as the corrupted one, copy it to the same directory and overwrite the corrupted file. Now you should be able to delete it. For directories, try to create a new file inside the corrupted directory and then delete the directory. Apr 12, 2022 at 9:32

13 Answers 13


Perhaps try ntfsfix (or similar program) in your favourite linux (or knoppix).
Usually located in package 'ntfsprogs'.

Sometimes trying to delete from Linux (with ntfs-3g or other ntfs-write-support) helps.

Knoppix (Linux-Live-CD/DVD): http://www.knoppix.net/

  • Thanks, this was the only suggestion that actually worked. Great :-)
    – 0xA3
    Sep 21, 2009 at 9:47
  • 1
    Just a note I had a user w/ the same issue - some old ie .dll leftover from a Win7 -> Win10 upgrade, that was interfering w/ backups due to VSS shadowcopy creation failing. Tried accessing it offline, booted off WinPE, etc., whichever NTFS package that Linux Mint uses did the trick. (Do be sure to re-run chkdsk against all partitions on the drive afterward. )
    – Orangutech
    Jul 27, 2017 at 0:03

From what I remember a Startup Repair should repair the FS and remove the files.

for a howto see : http://windowshelp.microsoft.com/Windows/en-US/help/5c59f8c1-b0d1-4f1a-af55-74f3922f3f351033.mspx

As always when using this type of stuff, best to backup the system before


Give it a try from a command prompt. If that still doesn't work try doing the same from safe mode.

  • Thank you for that tip. However, the problem seems not related to any process having an open handle to these objects. It seems related to a serious FS corruption. Are there any tools to fix that besides chkdsk?
    – 0xA3
    Sep 16, 2009 at 8:20
  • Sorry, I can't think of any other utilities to try. If this is a system drive and you ran chkdsk from inside Windows try having it run during a reboot. Windows itself may be interfering. Sep 16, 2009 at 8:38

I've never done it with a folder but my fix for files that won't let you delete them under Windows is to do the following from the command-line:

echo "blah" > <filename>

It's worked for me every time :)

  • 1
    Unfortunately this gives "The file or directory is corrupted and unreadable." I suppose I rather needed a tool fixing serious NTFS corruption before I can delete those files.
    – 0xA3
    Sep 16, 2009 at 8:17
  • that's a shame - I've successfully employed that when needing to kill files from my BT folder after I'd shutdown the BT client
    – warren
    Sep 16, 2009 at 10:14
  • "The file or directory is corrupted and unreadable."
    – OhadR
    Dec 23, 2016 at 8:01

If this is really a badly corrupted filesystem issue, I would move whatever data off you can and then reformat the drive. It could also be an issue with failing hardware causing the corruption so be aware of that and check it if you can.


Two things I might try:

  1. Create a temporary folder ("delete_me"), and see if you can move the corrupted directory into this folder, then attempt to get rid of "delete_me".

  2. Boot from a linux-based distribution that has NTFS filesystem support (such as Ubuntu) and delete it from there.

  • Gah! I see that ppuschmann had more-or-less the same linux-based suggestion. I still think the linux-based rm and checkdisk option is the most likely to give you positive results if the MS-based checkdisk isn't fixing it for you.
    – Stéphane
    Sep 18, 2009 at 18:59

You problably have a badblock on that drive. Try Ultimate Boot CD. It contains tons of useful tools.


When you see the error "0x80070570 can't access files" on install click --> OK ---> you will be returned to the "Install Now" startup screen and - WITHOUT REBOOTING - just re-start the install


Try deleting the folder that contains the corrupted file/folder (move your precious files out first).


Not sure how well it will work with a corrupted file. But whenever I need to delete something that the OS does not want me to Unlocker really helps out.

Give it a try. It might just work for this scenario too.


I had this happen last week. We popped the drive out and installed it in a system that had no issues, then check disk was able to fix it, though safe mode was not.


go to properties for trash bin change to bypass trash and should be able todelete corrupted file.

  • 1
    so far this is the simplest solution,works everytime
    – wjs57
    Oct 31, 2010 at 14:26

Some googling found this comment:


linking to a Windows util:


According to the original poster, this fixed the problem.

  • Downvoted for having a signature on each of your answers...despite being told they were frowned upon.
    – GregD
    Dec 1, 2009 at 21:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .