6

When I logon my Server 2012 R2 server via Remote Desktop it sits at the logon screen for 10-20 seconds before logging me in. Once logged in I find the following three errors in the Windows System Event log, all logged as Event ID 7011 with the source Service Control Manager:

A timeout (30000 milliseconds) was reached while waiting for a transaction response from the UmRdpService service.


A timeout (30000 milliseconds) was reached while waiting for a transaction response from the ScDeviceEnum service.


The Smart Card Device Enumeration Service service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion.

Apparently the UmRdpService is the RDP Port Redirector service, so I suppose when I am establishing a Remote Desktop session to my server, RDP is trying to redirect a smart card. But I don't have a smart card device of any sort attached to my server or the machine from which I am making the remote connection.

I checked the Smart Card Device Enumeration Service service and noted its Startup Type is Manual (Trigger Start). I can start and stop the service manually and no errors are logged.

How can I prevent this unnecessary delay when logging in?

6

If you don't have a need to use Smart Cards for authentication, change the Startup Type of the the Smart Card Device Enumeration Service from Manual (Trigger Start) to Disabled. After doing so the unwanted delay on remote logon will disappear.

  • 1
    in order to this from command line, stop the service and disable it from boot: net stop scdeviceenum sc \\servername config scdeviceenum start= disabled – kamihack Apr 13 '16 at 16:28
0

I had been searching a while to solve the issue of not being able to log back on the 2012R2 server Remote Desktop. Either it would freeze the existing clients logged in and/or when you would RDP connect it never got to the Server login prompt but instead a black screen. Nothing resolved this except to reboot the RDS Server (2012R2). By disabling disable the Large Send Offload on both the Remote desktop Server it resolved everything. All red herring errors and warnings pointing me everywhere but to the solution that actually worked stopped. Once I saw that this worked immediately, then I also disabled the Large Send Offload on the domain controller as well. Thank you

  • This sounds like an answer to a different question. In your case it never got to the server logon prompt but instead a black screen but the OP's problem is that it sits at the logon screen 10-20 seconds. – Twisty Impersonator Sep 11 '16 at 21:47
0

On the Windows Server 2012 machine, disable the Large Send Offload via the following steps:

  1. Open Network Connections.
  2. Right-click the icon of the Network card and select Properties.
  3. In Networking tab, click Configure… button.
  4. In the next window, switch to Advanced tab.
  5. Click the Large Send Offload Version 2 (IPv4) and change the value to Disabled.

You should notice a difference straight away.

  • Interesting solution. Are you also getting the same errors logged in the event log on slow logon? – Twisty Impersonator Jul 27 '16 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.