how can I create a Public/Shared Mailbox on OS X Server? This Mailbox should be available to all authenticated Users on my network and should be automatically subscribed into a folder "Public" in the Mailbox folder structure. The folder structure in the IMAP inbox should look similar to this:

  |- User-Folder1
  |- User-Folder2
  |- Public-Mailbox-1
  |- Public-Mailbox-2
  |- Public-Mailbox-3

What I have done so far:

  • I created a User in the LDAP-Directory with an email address "[email protected]" <- Only as workaround to get a mailbox
  • I modified this file: /Library/Server/Mail/Config/dovecot/conf.d/15-mailboxes.conf and added this lines at the end:

    namespace {
        type = public
        separator = .
        prefix = Public.
        location = maildir:/Volumes/Data/Library/Server/Mail/Data/mail/users/accounts/
        subscriptions = yes
        list = yes
        mailbox Public {
                auto = subscribe

When I login into my IMAP account on the server via webmail (roundcube) I can see the folder in the IMAP "Manage folders" but I can not subscribe to it. Has anyone an idea how I can get this?

Is it also possible not to create an LDAP User, to get an Mailbox for some special email addresses (accounts, info)?

Thanks Oliver

Version Numbers: OS X 10.9.5 Server App 3.2.1 (clean install no update) Postfix: postconf -d | grep mail_version mail_version = 2.9.4 Dovecot: sudo dovecotd --version 2.2.5

Info: Also posted here: https://discussions.apple.com/message/26829189

1 Answer 1


At least with 10.10, the ACL plugin is enabled, so I believe you will have to declare some permissions for the folder.

Inside /Volumes/Data/Library/Server/Mail/Data/mail/users/accounts/, add a file named dovecot-acl and add ACL rules as per http://wiki2.dovecot.org/ACL.

In my case, I wanted all users to have non-admin access, so my file contains this one line:

anyone lrwstipe

Also, I'm not sure you want subscriptions=yes. If that's no, then the subscriptions to that folder are managed by the parent, which is each users' account.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .