0

Recently while installing Oracle 12C DB on Windows server 2008 R2. I created an user called Oracle through the Oracle DB installation setup. Now am unable to login remotely into the machine with this user, though user is in Remote Desktop Users Group. Is there a solution for this?

  • What does "unable to login remotely" mean? What kind of error message are you seeing? – Evan Anderson Oct 17 '14 at 9:46
  • "To Logon to this remote computer, you must be granted the allow on through terminal services right. By default members or Remote Desktop Users group have this rights. " this is the error message, even after adding the user to the Remote Desktop Users group. – dunantsm Oct 17 '14 at 9:51
  • 1
    Sounds like the Oracle installer played around with your User Rights Assignment. Double check the "Deny Logon Locally" user right in Local Security Policy. – Evan Anderson Oct 17 '14 at 9:57
  • To be clear; this is a Windows user NOT an Oracle database user, correct? – joeqwerty Oct 17 '14 at 16:23
0

I solved the problem in 11g by creating a password file with the following.

1) login as the ORACLE owner

2) cd $ORACLE_HOME/dbs

3) orapwd file=orapw$ORACLE_SID password=yourpasswordhere

4) login to Oracle as SYSDBA locally (sqlplus "/ as sysdba")

5) Enable the remote login password parameter in the spfile (alter system set REMOTE_LOGIN_PASSWORDFILE=exclusive scope=spfile;)

If you're using a pfile, add the parameter to init$ORACLE_SID.ora instead.

6) bounce the database

Next, the IPSOFT user must be granted SYSDBA on the primary DB.

7) login to Oracle as SYSDBA locally (sqlplus "/ as sysdba")

8) GRANT SYSDBA to IPSOFT;

Third, copy the passwordfile created in step 3 ($ORACLE_HOME/dbs/orapw$ORACLE_SID) to the same directory on the standby site.

9) Example command: scp $ORACLE_HOME/dbs/orapw$ORACLE_SID standbysite:/u01/app/oracle/product/11gR2/dbs/orapw$ORACLE_SID)

10) Bounce the standby and verify that it is recovering from the primary properly in managed recovery mode.

11) Completed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.