0

I'm trying to download a previous version of mysql-server (5.5.28-0ubuntu0.12.04.2) using apt-get, but I can't seem to find the source list with the version that I want.

I've done apt-get update to try to update my source list, but when I do apt-cache madison mysql-server all it shows is 5.5.22 and 5.5.40. and when i try to put in all sorts of version numbers apt-get install mysql-server=xxx (5.5.26, 5.5.28-0ubuntu0.12.04.2, etc.) all it tells me is that that version was not found. Is there a website with apt-get source lists for previous versions of programs? Or am I typing in the version number incorrectly? Thank you in advanced for your help!

  • you can always grab it here launchpad.net/~ubuntu-security/+archive/ubuntu/ppa/+build/… – Mike Oct 17 '14 at 18:51
  • I've run into problems with trying to install packages manually because of all the dependencies I've needed to get a hold of. It's been a lot easier to use apt-get, and I'd like to try before resorting to hunting down every deb file. Thanks though! – Peter Hyoung Oct 17 '14 at 21:30
0

Installing the MySQL "linux generic" binary (pre-compiled, not "source") distribution from the tarballs is painfully straightforward... you extract the tarball, cd into the directory, and start it, and multiple versions coexist on the same machine, in different directories, with no conflict... On Ubuntu, the only noteworthy dependency is libaio1, which you already likely have.

But, if you really want to use the package manager, the old version deb files (or rpm, or source) are still downloadable... as well as the binaries: http://downloads.mysql.com/archives/community/

These won't likely be the same exact thing apt-get would find, since these are the "official" releases, and many distros build their own, so the default install directories may be different.

  • Hey. Thanks for your answer. So I downloaded mysql-5.5.28-linux2.6-x86_64.tar.gz on my Ubuntu 12.0.4 server and untared it into the /var/lib/mysql directory. I tried to start it using /etc/init.d/mysql start, but it hasn't been working. It says Rather than invoking init scripts through /etc/init.d, use the service(8) utility, e.g. service mysql start initctl: Unknown job: mysql Since the script you are attempting to invoke has been converted to an Upstart job, you may also use the start(8) utility, e.g. start mysql. I've tried to recommendations, but no go. How do I start it? – Peter Hyoung Oct 21 '14 at 5:29
  • From inside the directory, sudo nohup bin/mysqld_safe &. – Michael - sqlbot Oct 21 '14 at 10:33
0

According to https://launchpad.net/ubuntu/precise/amd64/mysql-server, that particular version has been superseded by mysql-5.5 5.5.29-0ubuntu0.12.04.1 (which in turn has a long chain up to 5.5.40-0ubuntu0.12.04.1).

I'm guessing that most mirrors remove superseded versions to save space. With a little searching around, you can probably find a mirror (maybe http://mirror.esc7.net/pub/Ubuntu/pool/main/m/mysql-5.5/) with the files you need, fetch them, and then manually install with something like sudo dpkg -i *.deb.

  • Hello. Thanks for your answer. So I've been going through the mirror you provided and I've been trying to download every dependency manually, but it just seems endless. Plus, I ran into a wall because I couldn't find the right version of libc6 and it just seems like downloading mysql with all the right dependencies this way is going to be too much. If you have any other suggestions I'd gladly take them. Thanks again for the suggestion. – Peter Hyoung Oct 21 '14 at 5:31
  • It seems odd that version of MySQL on Ubuntu would be compiled against a different libc6. Which version of Ubuntu are you running? – Andy Shinn Oct 21 '14 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.