0

We used to work with windows network paths to connect to git, but starting to use team city we want to use SSH.

I'm having trouble testing a connection to a git repo on a server here at 192.168.X.XXX in the local network over SSH: This server has a secondary disk D: containing the Git central/bare repositories at

D:\Git\MyProjectName.git\

The ssh user has an Initial terminal shell directory of

D:\Git

This is set up as Fetch-Url in team-city:

ssh://ourgitusername@192.168.X.XXX:22/MyProjectName.git

We installed bitvise WinSSHD as the ssh server, and I'm able to connect to it using putty, and I can browse that folder ,the git repo IS a bare repository, yet I'm getting the error

List remote refs failed: org.eclipse.jgit.errors.NoRemoteRepositoryException: ssh://ourgitusername@192.168.X.XXX/MyProjectName.git: fatal: ''/MyProjectName.git'' does not appear to be a git repository

I tried changing the home directory, and Have tried about 10 different styles of writing that path, it still won't work...!

0

Have you tried using '\' instead of '/' after the IP?

  • Yes, that doesn't work either – Mvision Oct 21 '14 at 7:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.