0

I'm trying to create a group policy that applies printers to a specific user security group, but facing difficulties.

When loading a GPO with 4 printers in it, all but two PCs load all 4 printers. The two that don't, list the other 3 printers in the same GPO without any issues. The problematic machines are both running Windows 7 and Domain Controller is Windows 2008 R2.

This is what I've tried...

  • "point and click" printer install via "add printer" on offending machines. This correctly downloads the drivers an loads the printer.
  • Numerous "gpupdate /force /sync" and reboots, the GPResults report doesn't even mention the missing printer. Looking at the Events Viewer I also see no errors.
  • Reconfigure printer on print server
  • Delete existing driver from "print manager" on print server.
  • Re-install printer driver on print server.
  • Set driver isolation = shared.
  • Tried finding "packaged version" of HP P1606dn driver, but failed
  • tried finding driver path, in print management > drivers, but failed
  • installed hp universal PCL driver, but failed

GPO is configured as follows

  1. user policy > preferences > control panel settings > printers
  2. printers are loaded from the printer directory as "shared"
  3. Policy "creates" printers every time the user logs in
  4. Run in logged-on user's security context (user policy option) is checked for each printer
  5. Point and print restrictions are disabled
  6. On log-off a VBScript is run to unload all Network Printers
  7. Security filtering is on Authenticated Users, within a given OU.

Anybody got any ideas on how to troubleshoot/identify/fix the cause of this problem?

I'm thinking it has something to do with driver install on print server and the fact that the driver i installed is neither packaged, nor does it have an "inf" path. Anyone know how to do this for an HP1606dn printer?

Update: I tried loading the profile on a different PC with no problems. Tried manual install of printer drivers on offending PC and got a permissions error on local admin. Pursuing this further, will keep posted if I have an answer.

  • Anybody got any ideas on how to troubleshoot/identify/fix the cause of this problem? RSOP.msc and gperesult should always be your first steps in troubleshooting a GPO issue. – HopelessN00b Oct 22 '14 at 7:51
  • Hi, thanks for answer. GPResult and RSOP.msc run on offending machines don't even list the printer in the policy settings, while others in the same GPO do. For some reason the printer in the GPO is not being "fetched". Security filtering is on Authenticated User who also has read access. – Dimitri Shukuroglou Oct 22 '14 at 8:41
  • Sometimes GPOs 'go bad', have you tried recreating the settings in a new GPO? – BlueCompute Oct 29 '14 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.