-1

My browser uses my PC's proxy setting. As far as I can see it uses some $http_URL. So, I put

https_proxy=$http_URL
http_proxy=$http_URL

The http connection work fine

wget $http_URL

but I can't get https connection to work. The error I get is

Connecting to autocache.xxx.com|x.x.x.x|:80... connected.
OpenSSL: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

Since the proxy setting works on the browser, maybe missing some setting in wget?

Some other post mentioned the error is because my connection is not targeting port 443 on the target host. I would have thought

wget $https_URL

should be going to port 443?

Any help welcome.

1 Answer 1

0

Turns out, with the http_proxy setting if i replaced instead of the command https://, to wget http://some.domain.com:443/path

Then it works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.