I am having a whole lot of trouble getting some files distributed across the network. My settings are:

Action: Replace
Source: \\[fqdn]\Repo\sqljdbcl.jar
Destination: %ProgramFiles%\Java\jre1.8.0_25\lib\ext\sqljdbc.jar

Attributes:
Read Only

Common:
All unchecked, no targeting

The error I am receiving is from event viewer, application log:

The computer 'sqljdbc.jar' preference item in the 'Default Domain Policy 
{31B2F340-016D-11D2-945F-00C04FB984F9}' 

Group Policy object did not apply because it failed with error code '0x80070003 

The system cannot find the path specified.' This error was suppressed.

What's strange to me is that I am able to copy another file from that same folder, using the same path and same settings, but to a different destination folder.

What's even stranger is that on the target computers, the file appears to be at the appropriate destination and the appropriate size, but with zero functionality.

  • 1
    Just for clarification: You're doing this in the "Computer" portion of a Group Policy Object. The source sqljdbc.jar file is readable by the "Domain Computers" group. What is the content of the file that's being copied down to the machines. You say "zero functionality" but that doesn't describe what's actually in the file. Run a hexdump of the file or just open it in Notepad (and brave the ugliness). Finally, it's really not "best practice" to modify the "Default Domain Policy". A lot of people do it, to be sure, but it's best to leave it stock and make new GPOs with your settings in them. – Evan Anderson Oct 24 '14 at 15:15
  • Thanks for the info. The GPO is in "Computer" and "Domain Computers" has both NTFS and Share permissions to the file. I'll have to run a hexdump and see if they match. The issue is that the Java app I've written isn't able to make calls to what's int the .jar library. – NonSecwitter Oct 24 '14 at 15:31
  • I will also take your advice on where to apply the GPO. Do you not make any settings on the default GPO? – NonSecwitter Oct 24 '14 at 16:11
  • 1
    That's correct. I do not generally make any modifications to the "Default Domain Policy" or "Default Domain Controllers Policy". I want to able, in a troubleshooting scenario, to disable any GPOs I created and return the behavior of the product back to the "stock" behavior. I create and link new GPOs with my settings in them instead. – Evan Anderson Oct 24 '14 at 16:25

This is a very common mistake. The problem is the %ProgramFiles% environmental variable. Group Policy Preferences has its own set of environmental variables, which are different than what you're used to. Please see http://technet.microsoft.com/en-us/library/cc753915.aspx for more information. You can also press F3 in any Group Policy Preferences dialog to see this list. You probably want to use %ProgramFilesDir% instead. The access denied error is common when the path you're trying to access doesn't exist.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.