-3

I am having an issue with PostFix and Dovecot. I followed this guide: https://github.com/opensolutions/ViMbAdmin/wiki/Mail-System-Install-on-Ubuntu and when mail is sent into the server, this is in the mail.log

Oct 26 12:40:11 vps31465 postfix/smtpd[13551]: connect from nm3-vm2.bt.bullet.mail.ir2.yahoo.com[212.82.99.122]
Oct 26 12:40:11 vps31465 postfix/smtpd[13551]: warning: SASL: Connect to private/dovecot-auth failed: No such file or directory
Oct 26 12:40:11 vps31465 postfix/smtpd[13551]: fatal: no SASL authentication mechanisms
Oct 26 12:40:12 vps31465 postfix/master[13383]: warning: process /usr/lib/postfix/smtpd pid 13551 exit status 1
Oct 26 12:40:12 vps31465 postfix/master[13383]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling

This is my output from postfix -n:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
home_mailbox = Maildir/
inet_interfaces = all
mailbox_command = /usr/lib/dovecot/deliver -c /etc/dovecot/dovecot.conf -m "${EXTENSION}"
mailbox_size_limit = 0
mydestination = polynet.me, vps31465.vps.ovh.ca, localhost.vps.ovh.ca, localhost
myhostname = vps31465.vps.ovh.ca
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_recipient_restrictions = reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_unauth_pipelining, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_path = private/dovecot-auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_restrictions = reject_unknown_sender_domain
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/dovecot/dovecot.pem
smtpd_tls_key_file = /etc/dovecot/private/dovecot.pem
smtpd_tls_mandatory_ciphers = medium
smtpd_tls_mandatory_protocols = SSLv3, TLSv1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom

And my Output from doveconf -n

root@vps31465:~# doveconf -n
# 2.2.9: /etc/dovecot/dovecot.conf
# OS: Linux 2.6.32-042stab093.5 x86_64 Ubuntu 14.04.1 LTS
mail_location = mbox:~/mail:INBOX=/var/mail/%u
managesieve_notify_capability = mailto
managesieve_sieve_capability = fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date ihave
namespace inbox {
  inbox = yes
  location =
  mailbox Drafts {
    special_use = \Drafts
  }
  mailbox Junk {
    special_use = \Junk
  }
  mailbox Sent {
    special_use = \Sent
  }
  mailbox "Sent Messages" {
    special_use = \Sent
  }
  mailbox Trash {
    special_use = \Trash
  }
  prefix =
}
passdb {
  driver = pam
}
plugin {
  sieve = ~/.dovecot.sieve
  sieve_dir = ~/sieve
}
protocols = " imap lmtp sieve pop3"
ssl_cert = </etc/dovecot/dovecot.pem
ssl_key = </etc/dovecot/private/dovecot.pem
userdb {
  driver = passwd
}

The domain is mail.polynet.me.

I don't know where I have gone wrong.

Help is greatly appreciated :)

  • postfix -n is not a working command. I think you meant postconf? – mc0e Oct 27 '14 at 9:37
5

OK, so firstly it looks like your incoming mail transaction is running into problems with SASL authentication.

Oct 26 12:40:11 vps31465 postfix/smtpd[13551]: warning: SASL: Connect to private/dovecot-auth failed: No such file or directory

That path looks to have come from here, in what I assume is postconf output (contrary to how you describe how you got it):

smtpd_sasl_path = private/dovecot-auth

That's a path to a socket, which is relative to $queue_directory. I'm not sure why that's not in your (assumed) postconf output. On my system it's /var/spool/postfix.

So check that that path exists (presumably it doesn't)

Your doveconf -n output actually looks like a repeat of your postconf output, so I can only do so much. On my system I have a stanza like so:

service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  }
}

Which creates the socket which postfix talks to to deliver email. You've named your socket file dovecot-auth instead of auth, which seems sensible enough. I'm guessing though that you have something wrong in configuring that socket for postfix to talk to.

Please fix the configuration listings in your question, or I might have to down-vote it.

EDIT: I took a look at the link you've been using. It refers to a gist with instructions for dovecot setup, which I think you've missed entirely.

| improve this answer | |
  • Thanks. I have updated the original post now, and await further assistance :) – JoeM Oct 26 '14 at 18:48
0

Now i ave progressed a litle bit further, I have the following issues.

    Oct 26 18:07:54 vps31465 postfix/lmtp[14820]: 751721E2624: to=<test@polynet.me>, relay=none, delay=0.44, delays=0.43/0.01/0/0, dsn=4.4.1, status=deferred (connect to vps31465.vps.ovh.ca[private/dovecot-lmtp]: No such file or directory)
Oct 26 18:07:54 vps31465 postfix/smtpd[14812]: F38391E2628: client=nm5-vm2.bt.bullet.mail.ir2.yahoo.com[212.82.99.124]
Oct 26 18:07:55 vps31465 postfix/cleanup[14817]: F38391E2628: message-id=<1414360873.47140.YahooMailNeo@web87701.mail.ir2.yahoo.com>
Oct 26 18:07:55 vps31465 postfix/smtpd[14818]: disconnect from nm5-vm2.bt.bullet.mail.ir2.yahoo.com[212.82.99.124]
Oct 26 18:07:55 vps31465 postfix/qmgr[14797]: F38391E2628: from=<malloyj@btinternet.com>, size=18027, nrcpt=1 (queue active)
Oct 26 18:07:55 vps31465 postfix/lmtp[14820]: F38391E2628: to=<test@polynet.me>, relay=none, delay=0.41, delays=0.41/0/0/0, dsn=4.4.1, status=deferred (connect to vps31465.vps.ovh.ca[private/dovecot-lmtp]: No such file or directory)
Oct 26 18:07:55 vps31465 postfix/smtpd[14812]: disconnect from nm5-vm2.bt.bullet.mail.ir2.yahoo.com[212.82.99.124]
Oct 26 18:08:15 vps31465 postfix/smtpd[14818]: connect from localhost[::1]
Oct 26 18:08:15 vps31465 postfix/smtpd[14818]: BA6271E262C: client=localhost[::1]
Oct 26 18:08:15 vps31465 postfix/cleanup[14817]: BA6271E262C: message-id=<20141026220815.BA6271E262C@vps31465.vps.ovh.ca>
Oct 26 18:08:15 vps31465 postfix/qmgr[14797]: BA6271E262C: from=<support@example.com>, size=2513, nrcpt=1 (queue active)
Oct 26 18:08:15 vps31465 postfix/smtpd[14818]: disconnect from localhost[::1]
Oct 26 18:08:15 vps31465 postfix/lmtp[14820]: BA6271E262C: to=<test@polynet.me>, relay=none, delay=0.54, delays=0.54/0/0/0, dsn=4.4.1, status=deferred (connect to vps31465.vps.ovh.ca[private/dovecot-lmtp]: No such file or directory)

I am unsure how to move forward from this. These are my current Postfix config:

# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file = /etc/dovecot/dovecot.pem
smtpd_tls_key_file = /etc/dovecot/private/dovecot.pem
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
myhostname = vps31465.vps.ovh.ca
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination =  vps31465.vps.ovh.ca, localhost.vps.ovh.ca, localhost
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = /usr/lib/dovecot/deliver -c /etc/dovecot/dovecot.conf -m "${EXTENSION}"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
home_mailbox = Maildir/
smtpd_sasl_auth_enable = yes
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
smtpd_sasl_authenticated_header = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myhostname
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sender_restrictions = reject_unknown_sender_domain
smtp_use_tls = yes
smtpd_tls_received_header = yes
smtpd_tls_mandatory_protocols = SSLv3, TLSv1
smtpd_tls_mandatory_ciphers = medium
smtpd_tls_auth_only = yes
tls_random_source = dev:/dev/urandom
virtual_alias_maps = mysql:/etc/postfix/mysql/virtual_alias_maps.cf
virtual_gid_maps = static:2000
virtual_mailbox_base = /srv/vmail
virtual_mailbox_domains = mysql:/etc/postfix/mysql/virtual_domains_maps.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql/virtual_mailbox_maps.cf
virtual_minimum_uid = 2000
virtual_uid_maps = static:2000
#dovecot_destination_recipient_limit = 1
virtual_transport = lmtp:unix:private/dovecot-lmtp

And my dovecot:

 root@vps31465:/etc/dovecot# dovecot -n
# 2.2.9: /etc/dovecot/dovecot.conf
# OS: Linux 2.6.32-042stab093.5 x86_64 Ubuntu 14.04.1 LTS
mail_location = mbox:~/mail:INBOX=/var/mail/%u
managesieve_notify_capability = mailto
managesieve_sieve_capability = fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date ihave
namespace inbox {
  inbox = yes
  location =
  mailbox Drafts {
    special_use = \Drafts
  }
  mailbox Junk {
    special_use = \Junk
  }
  mailbox Sent {
    special_use = \Sent
  }
  mailbox "Sent Messages" {
    special_use = \Sent
  }
  mailbox Trash {
    special_use = \Trash
  }
  prefix =
}
passdb {
  driver = pam
}
plugin {
  sieve = ~/.dovecot.sieve
  sieve_dir = ~/sieve
}
protocols = " imap lmtp sieve pop3"
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  }
}
ssl_cert = </etc/dovecot/dovecot.pem
ssl_key = </etc/dovecot/private/dovecot.pem
userdb {
  driver = passwd
}

Any Ideas what I am missing now??

| improve this answer | |
  • You're not really on the same question any more. Different problem this time, different symptom, etc. No sign that you've gotten authentication working - you're probably just running an open relay. Maybe you should employ someone for a few hours to help you get started? – mc0e Oct 27 '14 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.