I have an ubuntu server and a static IP address. When I try to ping my IP static ip from my internal network it work but, when I try from external link remote ping

I haven't no response!!

#cat /etc/hosts localhost XUbuntu

#netstat -tapn

tcp 0 0* Listen
tcp 0 0* Listen
tcp6 0 0 ::1:443 :::* Listen
tcp6 0 0 ::1:80 :::* Listen
tcp6 192.168.1.XXX:80 192.168.1.myip:59047 ESTABLISHED

My router is DLink 868l branded Optimum .... I added the port forward rule. The problem is in the router or in y ubuntu server???? Obviously if I can't ping the ip address for me is impossible put up online my website!

  • check the firewall rules on dlink, do you have rules before port forward, which are blocking icmp, or any type of outside access to static IP?
    – ralz
    Oct 27, 2014 at 14:06
  • "Obviously if I can't ping the ip address for me is impossible put up online my website". That's not true, as TCP may get through where ICMP doesn't. The best way to find out if the firewall rule for the website is working is to test the website from an external IP address. Oct 27, 2014 at 14:10

1 Answer 1


Ping uses ICMP as a protocol. Your web site would be accessed via TCP, which is a different protocol and is most often handled differently by firewalls and routers. It is not uncommon for ICMP packets to be blocked at a router, particularly from an external source.

You should test access to your web server via a browser from an external location to see if the firewall rules are correct and if you have correctly forwarded the traffic.

  • I said this because when I try to connect on my webserver I have the error 504 ... gateway timeout so I tried to ping my static ip address because I need to understand if the problem is in the router setup! ... PS: When I try to connect into my webserver from internal network my website work!! ... PPS: My ubuntu server is a virtual machine in Hyper Manager V ... I've checked the windows2012 firewall server and its ok!!
    – Fabio
    Oct 27, 2014 at 20:31
  • I've tried to disable the windows firewall but its the same... error 504...
    – Fabio
    Oct 27, 2014 at 21:24

Not the answer you're looking for? Browse other questions tagged .