0

After last reload nginx i have error nginx: [emerg] chown("/gypost/uploads/00", 1001) failed (1: Operation not permitted)

192.168.0.91:/gypost/mail/u
                      247G   17G  218G   7% /gypost/uploads

it's a mounted directory

exports for this client:

/gypost/mail/u  192.168.0.93(rw,insecure,nohide,sync,no_subtree_check,anonuid=1003,anongid=33,no_all_squash)

fstab in client:

192.168.0.91:/gypost/mail/u     /gypost/uploads         nfs     rw,auto         1       3

In location nginx block:

upload_store /gypost/uploads/00;

A few days ago, it was working correctly. Where problem?

I found the problem, why nginx could not chown. In mount point was several files with permissions 500 (do not know where they came from). But why mounting occur under wrong user, i did not understand (but it does not matter for me).

  • fstab config 192.168.0.91:/gypost/mail/u /gypost/uploads nfs rw,auto 1 3 – Kostiuk Aleksandr Oct 28 '14 at 11:02
  • mounting on .93 (where installed nginx) occurs under the wrong user, but exports in .91 set correctly. 1003 it's uid of wrong user(anonuid=1003 for local user, or no?), but i tried set anonuid of user on .93, result is similar. Sorry for my english) – Kostiuk Aleksandr Oct 28 '14 at 15:34
  • I have 1 more export line /gypost/mail/u 192.168.0.92(rw,sync,no_subtree_check,anonuid=1003,anongid=33,all_squash), it work correctly. I tried use similar options for .93, but mounting again for wrong user, pls help me) – Kostiuk Aleksandr Nov 3 '14 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.