0

So I just set up ganglia on a single debian node. It followed a pretty simple process of

1 - installed from stable repo using

apt-get install ganglia-monitor gmetad
apt-get install ganglia-webfrontend

2 - configured using using: https://www.digitalocean.com/community/tutorials/introduction-to-ganglia-on-ubuntu-14-04#installation

Now I have everything running and I can access it on localhost/ganglia and it shows the grid memory, network, and load but not CPU. The CPU total is 0, hosts up and down are 0 and there is no avg load or utilization.

Just to be clear this is debian wheezy, I am only running it on a single node that is running both gmetad and gmond so thus reporting to itself. Is there further setup I need to do or does anyone know what could be the cause of this problem and lack of information?

1

Strangely this isn't well documented or possibly I just did a poor job finding the docs but I had to change /etc/ganglia/gmond.conf to this, restart everything, and now it works just fine:

  udp_send_channel {
    host = 127.0.0.1
    port = 8649
    ttl = 1
  }

  udp_recv_channel {
    port = 8649
    family = inet4
  }
  udp_recv_channel {
    port = 8649
    family = inet6
  }

Hopefully this helps anyone else who was setting up a single node and master!

PS in the same file don't forget to change mcast_join = 127.0.0.1 to host = 127.0.0.1

  • I tried it and in udp_send_channel the host with 127.0.0.1 is critical as localhost did not work for me – Venkat Krishnan Sep 23 '15 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.