1

I did a minimal CentOS 6.4 install (x64) and now I need to install Java JRE 32 bits. However, everywhere I read, I understand the .i386 or .i686 packages should be available by default. I cannot find any tutorial with something like "Add this repo for 32 bit packages" and also I am a newbie with YUM as my experience has been mostly with aptitude and deb packages.

So other than downloading the rpm from the web and using the rpm tool, is there any way to have the option to install 32 bit libraries and binaries from yum?

The reason I need this is to make this particular version of Eclipse (provided by a company for their processor). When I do ./eclipse I get:

OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m;
support was removed in 8.0
OpenJDK 64-Bit Server VM warning: You have loaded library
/home/usuario/eSi-RISC/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.200.v20130521-0416/eclipse_1506.so
which might have disabled stack guard. The VM will try to fix the
stack guard now.
It's highly recommended that you fix the library with 'execstack -c
<libfile>', or link it with '-z noexecstack'.
Eclipse:
JVM terminated. Exit code=13
/usr/bin/java
-Dosgi.requiredJavaVersion=1.6
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /home/usuario/eSi-RISC/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
-os linux
-ws gtk
-arch x86
-showsplash /home/usuario/eSi-RISC/eclipse//plugins/org.eclipse.platform_4.3.0.v20130605-2000/splash.bmp
-launcher /home/usuario/eSi-RISC/eclipse/eclipse
-name Eclipse
--launcher.library
/home/usuario/eSi-RISC/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.200.v20130521-0416/eclipse_1506.so
-startup /home/usuario/eSi-RISC/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
--launcher.appendVmargs
-exitdata f0003
-product org.eclipse.epp.package.cpp.product vm
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.25-1.b17.el6.x86_64/jre/bin/java
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.6
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /home/usuario/eSi-RISC/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar

In my other machine (uses debian) I installed java 32 bit and added the line:

-vm /usr/lib/jvm/java-7-openjdk-i386/jre/bin/java

And this made it work. However one of the programs in the toolchain requires a library that I cannot find in Debian. When I asked they told me they have their SDK working in CentOS. However, they did not tell me which architecture. I'm betting it was a 32 bit architecture and this is why I can't get it to work.

I hope this clarifies the problem.

  • 1
    Are you absolutely certain you need a 32-bit JRE? – Michael Hampton Oct 31 '14 at 12:58
  • Yes, unfortunately. 100%. It has been the only way to make the program that I need work, as it was all written in 32 bits (by the company that provided it), and I don't feel like changing the OS. By the way the company assured us that It worked in CentOS, however it did no specify which architecture. I'm betting it was a 32 bit arch. – aarelovich Oct 31 '14 at 13:06
  • Is there some very good reason you need to use their version of Eclipse rather than the system Eclipse or the upstream Eclipse? – Michael Hampton Oct 31 '14 at 13:48
  • Mainly, I have no idea how to set up the normal Eclipse to work with their toolchain. Since its completely propietary, there are no tutuorials, help, forums or questions. Only some (limited) contact with their support. – aarelovich Oct 31 '14 at 13:56
1

All you usually need to do in order to force the installation of a 32-bit package is to:

yum install package name.i686

This won't work for the java packages, but I don't think you'd need a 32-bit Java JRE... It normally shouldn't matter, but if you need it, you can pull the package down from http://rpm.pbone.net or a CentOS mirror.

  • Tried this and it doesn't work. I get that no package exists. – aarelovich Oct 31 '14 at 13:17
  • It's not supposed to work. There isn't much of a reason to require 32-bit Java. Have you tried to use the 64-bit java package with your application? What happens? In my answer, I stated that you could download the packages from CentOS mirror or rpm.pbone.net – ewwhite Oct 31 '14 at 13:29
  • I have to use a custom version of eclipse (provided by a company to create a development kit for their very own processor). The only way I have managed to make it work (on another machine) is adding the vm line in eclipse ini poiting to the 32 bit JRE. I'll post the problem in the question – aarelovich Oct 31 '14 at 13:33
  • But what happens with this machine? – ewwhite Oct 31 '14 at 13:34
  • It's in the edit. Sorry if I wasn't clear on what I was going to post. – aarelovich Oct 31 '14 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.