1

I have a Windows Server 2008 R2 OS where I just created a standard user account. I went into the Local Group Policy Editor and set the OS to only allow certain programs to be run. I figured that this change would apply to non-administrative accounts, but now my administrator account is locked out from opening any programs.

I cannot open the policy editor to revert this change, even if I right click > Run as Administrator. Any ideas on how to rollback this change?

4
  • 1
    Is that a member of a domain, or a standalone system. You should be able to remotely manage it using RSAT tools from a Windows 7 workstation or another 2008r2 system.
    – Zoredache
    Oct 31 '14 at 16:35
  • @Zoredache It's a standalone system Oct 31 '14 at 16:54
  • Restore from backups or use a boot disk/repair console to manually remove that group policy setting. Oct 31 '14 at 22:10
  • @HopelessN00b Yep, that's what I'm looking into doing. Just getting my repair disk together. Oct 31 '14 at 22:32
1

This really saved my server, try option 3: http://www.sevenforums.com/tutorials/214461-local-group-policy-reset-default.html

Note, this option will RESET ALL LOCAL GROUP POLICY options. Use with caution and at your own risk. First, you need to boot into a recovery disk and start up the recovery command prompt. Recreated here:


To Reset "Local Group Policy" to Default in a Command Prompt at Boot

  1. Open a command prompt at boot in Vista or Windows 7 or Windows 8. NOTE: See OPTION ONE at this link for how if needed.

  2. In the command prompt, type diskpart, and press Enter. (see screenshot)

  3. In the command prompt, type list volume, and press Enter. (see screenshot)

  4. Make note of what your Windows OS drive letter is. It is not always C: at boot. (see screenshot) NOTE: Mine just happens to be D: at boot.

  5. In the command prompt, type exit, and press Enter. (see screenshot)

  6. In the command prompt, type the command below, and press Enter. (see screenshot) NOTE: Substitute D in the command below with your drive letter from step 4 instead.

    RD /S /Q "D:\Windows\System32\GroupPolicy"
    
  7. In the command prompt, type the command below, and press Enter. (see screenshot) NOTE: Substitute D in the command below with your drive letter from step 4 instead.

    RD /S /Q "D:\Windows\System32\GroupPolicyUsers"
    
  8. Restart the computer back into Windows.

  9. The Local Group Policy Editor has now been reset back to default.

enter image description here

-1

Use the following command to edit Local Security Policy of a remote computer. You could also overwrite the local policy with Group Policy if you are joined to a Domain.

gpedit.msc /gpcomputer:"target"

Since, the computer is not joined to a Domain. Boot the server into Safe Mode and change the policy.

1
  • 2
    Safe mode does not affect this policy. Oct 31 '14 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.