I'm trying to install git from source using

make prefix=/Users/gareth/local/git install

but after installation nothing works properly, the commands all fail with, for example

git: 'pull' is not a git-command. See 'git --help'.

After some research I found out that the most obvious problem is this output:

$ git --exec-path

but I don't know why the exec-path is set to my home directory. The binaries are all in what appears to be the correct place, ~/local/git/libexec/git-core/git*

How can I work out what went wrong, and how to fix it?

  • 1
    Did you do ./configure --prefix=/Users/gareth/local/git ? – Pod Sep 10 '09 at 13:05
  • The INSTALL file, and the help I looked for on IRC, suggested that the make prefix= would be sufficient. Even so, I get the same result when I use that ./configure parameter – Gareth Sep 10 '09 at 13:15
  • 1
    See also the same question (different user) on SO: stackoverflow.com/questions/1465398/… – VonC Sep 23 '09 at 14:05

Maybe this is not really what you're looking for, but I would recommend you MacPorts.

With it, you can quickly build projects from sources and keeping them up-to-date. It will also handle any dependencies.


I think you're building Git the wrong way. You should be donig something like:

./configure --prefix=/Users/gareth/local/git
make install

Then make sure the git binary is on your path (and possibly git-receive-pack if you want to push via ssh from another machine).


I don't know the answer to your question, but as a workaround, consider installing Git for OS X. [There is a Build-Your-Own page on the wiki, but I'm not sure if it'll provide enough detail for what you want to do.]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.