I'm connecting from Windows Server 2012 R2 to Hyper-V virtual machine running Windows 8.1 via RDP (mstsc.exe). The VM is hosted on the same machine from which I'm connecting.
Everything was fine until today. When I connected to the VM today, I've seen that windows doesn't render properly and have random black rectangles as shown on the screenshot below: enter image description here This issue occures across all programs and any windows I'm trying to open, resize. scroll etc.

I've tried reconnecting to the VM, rebooting the VM, changing Windows themes on the VM, disabling and re-enabling display and display driver on the VM, changing resolution and color depth in the mstsc, disabling firewalls on both Server and VM to ensure ports are opened - nothing helped.

Does anybody has suggestions what else I can try to resolve this issue?

  • Any recent updates to either one of the machines? If you have a Win7 machine, try RDP from it. – EliadTech Nov 2 '14 at 8:54
  • Both server and VM machines have all the latest updates. Unfortunately, I don't have a Win7 machine to try. But I'm wondering why you suggesting it? Is Win7 version of mstsc 'better' than Win 2012 Server? – Alexander Abakumov Nov 2 '14 at 22:12
  • Saddly, so it would seem. I've tried it at work and the newer version was quiet sluggish and freezed occasionally. There might be some other reasons, but once I reverted back to the Win7 mstsc it worked perfectly. If you give it a try don't forget the mstscax.dll file too. – EliadTech Nov 3 '14 at 6:40
  • 1
    @EliadTech, Are you suggesting to downgrade the Win 2012R2 mstsc down to the Win7 mstsc somehow? How it could be done? Or just use the Win7 machine for RDP? to And what is the stuff about mstscax.dll? :) – Alexander Abakumov Nov 3 '14 at 7:57
  • First, this is not a solution for even if it'll work it won't solve the root problem itself - this is merely a workaround that you should try. A full solution would probably lie in reverting the recent changes you've made (either on the client or on the server). Second, it doesn't matter whether you run mstsc from Win7, or copy it. If you choose to copy, copy both mstsc.exe and mstscax.exe to one folder on the Win8.1 host. – EliadTech Nov 3 '14 at 8:59

I solved this issue by disabling Persistent bitmap caching in mstsc options for my VM:

enter image description here

After doing this, I haven't been experiencing any issues for several month.


There seems to be a problem with the auto detection of the connection quality. I had this sometimes in my environment.

I solved in mstsc.exe with setting under Experience the Detect connection quality automatically to a plausible value.


For me, disabling 'Persistent bitmap caching' as recommended here worked. However, this reduces performance.

Instead, deleting the contents of C:\Users\\AppData\Local\Microsoft\Terminal Server Client\Cache and connecting again worked. This way I was able to keep 'Persistent bitmap caching' turned on, but not have any black boxes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.